fading characters

for bbc micro/electron hardware, peripherals & programming issues (NOT emulators!)
Post Reply
eXne
Posts: 21
Joined: Wed Apr 06, 2016 7:15 am
Location: Assendelft, The Netherlands
Contact:

fading characters

Post by eXne » Sun Jan 13, 2019 8:36 pm

Folks,recently I purchased a BBC from the UK and started the normal process by first checking the PSU caps which needed to be replaced.
When I turned the Beeb on I was puzzled as I saw fading characters.
Pic-20190113-001.jpg
fading characters
After browsing the forum and google I found nothing similar, or I entered the wrong keywords :wink:
Memory seems to be ok, video ULA seems to be fine as well,
The 'puzzling graphics glitch on my Beeb' here was the base for the soluction.. and yes after some thinking: has this maybe something to do with the PSU not being earthed? As this is a UK machine I used an adapter with no earthing...
Installed an Earth connection and voila..
Pic-20190113-002.jpg
normal characters
Normally everybody starts with questions, this time I wanted to share


Etienne
Last edited by eXne on Mon Jan 14, 2019 12:16 pm, edited 2 times in total.
Acorn BBC + 6502 and Z80 2nd proc and CoPro, Master 128 + 80186

User avatar
tricky
Posts: 3466
Joined: Tue Jun 21, 2011 8:25 am
Contact:

Re: fading characters

Post by tricky » Sun Jan 13, 2019 11:47 pm

Does that mean that your video connection is missing a GND?

eXne
Posts: 21
Joined: Wed Apr 06, 2016 7:15 am
Location: Assendelft, The Netherlands
Contact:

Re: fading characters

Post by eXne » Mon Jan 14, 2019 7:37 pm

I need to dig into that part.
I have my beeb hooked through the RGB port to a TV Scart input.
Acorn BBC + 6502 and Z80 2nd proc and CoPro, Master 128 + 80186

Post Reply