Cracking tinnitus, Gromit

for bbc micro/electron hardware, peripherals & programming issues (NOT emulators!)
Post Reply
VMSZealot
Posts: 9
Joined: Fri Sep 21, 2018 6:48 pm
Contact:

Cracking tinnitus, Gromit

Post by VMSZealot » Fri Nov 09, 2018 10:53 pm

Ohh-Kay. So I finally got around to servicing the PSU of freebeeb, and tested the voltages. I’m getting a steady 4.98v on all power lines, with no strange smells or noises. However...

...when I plug the power lines into the motherboard, I get a continuous tone with a shrill edge to it - and no video. I’ve reseated all the chips, and re-heatsinked the ULA, but still the result is the same (I’ve checked the video out port and UHF. Nothing). The LEDs don’t light either.

The beeb is quite pimped. It’s got a sideways rom board and a ton of roms, expanded memory and a WE disk controller. When I tested the power with everything hooked up, the result was the same - steady 4.98v. That said, I can’t help wondering if one of the expansions is the culprit. What do I need to do to return this Beeb to ‘stock’? Presumably one or more of the ROMs might need rehoming on the main board?

Or does anyone have any other clever theories as to what might be amiss?

User avatar
1024MAK
Posts: 7988
Joined: Mon Apr 18, 2011 4:46 pm
Location: Looking forward to summer in Somerset, UK...
Contact:

Re: Cracking tinnitus, Gromit

Post by 1024MAK » Sat Nov 10, 2018 12:48 am

As it could be one of the expansions, the normal recommendation is to disconnect all the expansions. Unplug all ROMs except the OS ROM and the BASIC ROM.

However, before you remove or disconnect anything, please record what is where, and what connects to what. Including taking photos. Then post up the details. Someone here may spot a problem.

It could be something simple like a connection that has come loose.

As some of the expansion boards intercept signals, some links (jumper shunts) will have been removed. Once the expansions have been removed, you will need to reinstate these.

Details of the normal position of the links is detailed in the service manual.

If still no joy, try swapping the 6522 VIA chips.

If still no joy, go for the most minimal configuration. Details in this post.

Mark

Post Reply