Open Logic Sniffer client not working?

for all subjects/topics not covered by the other forum categories
Post Reply
User avatar
DutchAcorn
Posts: 2132
Joined: Fri Mar 21, 2014 9:56 am
Location: Maarn, Netherlands
Contact:

Open Logic Sniffer client not working?

Post by DutchAcorn » Fri Mar 17, 2017 3:31 pm

I have two sickly BBC's that I currently have time for to do some investigation on. I have an Open Bench Logic Sniffer that I have used before on a TRS-80.

The OLS Client software is supported through a website that has been off-line since 6 March. When trying to run the client, it now produces an error message. Apparently the client needs a link to the website.

Has anyone else experienced this? Any pointers on how to get the client to run?


Many thanks,
Paul

Image

User avatar
DutchAcorn
Posts: 2132
Joined: Fri Mar 21, 2014 9:56 am
Location: Maarn, Netherlands
Contact:

Re: Open Logic Sniffer client not working?

Post by DutchAcorn » Sat Mar 18, 2017 9:34 am

The site seems to be back up (sort of). I now downloaded Release 0.9.7 and that seems to work. :D
Paul

Image

User avatar
roland
Posts: 3395
Joined: Thu Aug 29, 2013 8:29 pm
Location: Born (NL)
Contact:

Re: Open Logic Sniffer client not working?

Post by roland » Sat Oct 12, 2019 9:40 am

I have downloaded version 0.9.7.2 and it causes a huge Java error on my Linux Mint 19 laptop. The same version used to work well on Mint 17. Does somebody know how to run this software on Mint 19 (which is based on Ubuntu 18)? The "official" forums seem a bit out of date.

Or does it run in an Virtual Box Windows XP environment, any experiences?
256K + 6502 Inside
MAN WOMAN :shock:

User avatar
hoglet
Posts: 8551
Joined: Sat Oct 13, 2012 6:21 pm
Location: Bristol
Contact:

Re: Open Logic Sniffer client not working?

Post by hoglet » Sat Oct 12, 2019 11:12 am

roland wrote:
Sat Oct 12, 2019 9:40 am
I have downloaded version 0.9.7.2 and it causes a huge Java error on my Linux Mint 19 laptop.
Can you post the Java stack trace.

What version of Java were you using on each of the systems?

User avatar
roland
Posts: 3395
Joined: Thu Aug 29, 2013 8:29 pm
Location: Born (NL)
Contact:

Re: Open Logic Sniffer client not working?

Post by roland » Sat Oct 12, 2019 5:46 pm

The java stack trace is in the attachment.

The first warning is: WARNING: An illegal reflective access operation has occurred
which can be suppressed with the java option --illegal-access=deny but then still it fails to run.

My current java version is:

openjdk 11.0.4 2019-07-16
OpenJDK Runtime Environment (build 11.0.4+11-post-Ubuntu-1ubuntu218.04.3)
OpenJDK 64-Bit Server VM (build 11.0.4+11-post-Ubuntu-1ubuntu218.04.3, mixed mode, sharing)

and I don't know the previous version of Java. Perhaps I can also download an older version of Java and use that one in my OLS directory.... ?
Attachments
java_error.txt
(30.99 KiB) Downloaded 2 times
256K + 6502 Inside
MAN WOMAN :shock:

User avatar
hoglet
Posts: 8551
Joined: Sat Oct 13, 2012 6:21 pm
Location: Bristol
Contact:

Re: Open Logic Sniffer client not working?

Post by hoglet » Sat Oct 12, 2019 5:56 pm

I think you need to be running OpenJDK version 8:

You could try installing it with:

Code: Select all

sudo apt install openjdk-8-jdk
I'm not sure how Linux Mint deals with multiple versions.

Dave

User avatar
roland
Posts: 3395
Joined: Thu Aug 29, 2013 8:29 pm
Location: Born (NL)
Contact:

Re: Open Logic Sniffer client not working?

Post by roland » Sat Oct 12, 2019 6:22 pm

That did the trick, I downloaded the file jdk-8u221-linux-x64.tar.gz and unpacked it as a subdirectory of the OLS package and then I modified the path to the java executable in run.sh.

This way it won't clash with other packages that need a newer version of java.

Let the capture begin :lol:
256K + 6502 Inside
MAN WOMAN :shock:

Post Reply