Page 1 of 1

ADFFS freezing after updates

Posted: Sat Jun 20, 2020 9:10 pm
by soviet
Hi currently experiencing an issue trying to play games using adffs.
The system in question is a RiscPC strongarm and have riscos 4.02 in rom.
Like always i have opened packman and when i check all updates and updated all packages on my system.
But after this ADFSS don't work anymore when i try to run the software i hear the floppy drive reading and then the system will freeze .
The rest of the software seems to be fine, i have downloaded older versions of ADFSS but the same happens in all of them.

Maybe some package that i update caused some kind of bug maybe someone have this issue before ?.

Re: ADFFS freezing after updates

Posted: Sun Jun 21, 2020 9:15 am
by sirbod
If I understand correctly, the games were working until you updated all packages, now they all hang? Could you name a few games you've tried that worked previously and if you downloaded them via PackMan?

I know I've fixed a lot of bugs that were breaking games on 3.x/4.x recently in the 2.73 beta, but I'm not sure updating will help in this situation. As you have a StrongARM you probably don't want to update to 2.73 beta as I've yet to implement to cache cleaning at VSync.

ADFFS doesn't really have any dependencies other than ZLib. I know ZLib on RISC OS 4.x has some bugs that mean it needs replacing with the ROOL version, 2.73 now does that automatically but I expect you've already RMKilled ZLib if you had it working previously.

Games obviously have dependencies on things like CLib, but that wouldn't get updated via PackMan.

Re: ADFFS freezing after updates

Posted: Wed Jun 24, 2020 6:19 pm
by soviet
Hi the issue is not that the games hang i don't get to that point.
When i run ADFFS i can hear the floppy drive read and then riscos freeze can't even move the mouse pointer.

And yes this happened after i updated all packages in packman when i performed the update i just allow all of them and don't checked was what updating.

Tried running older ADFFS versions from the website but the same issue happens.

Re: ADFFS freezing after updates

Posted: Wed Jun 24, 2020 10:07 pm
by sirbod
Go into the !ADFFS directory and try loading ADFFS550 manually to see if it hangs. If it doesn't hang, try loading ADFFSFiler.

Re: ADFFS freezing after updates

Posted: Wed Jun 24, 2020 11:32 pm
by soviet
Tested this and when try to load ADFFS550 i get the hang.

Re: ADFFS freezing after updates

Posted: Thu Jun 25, 2020 4:57 pm
by Daveo
I had it after a system lockup and had to restore my System directory from a backup, which fixed the hanging issue.

Also, make sure you're using the right ADFFSFiler version. It's inside !ADFFS and the version that comes with ADFFS v2.72 has to be replaced by v2.73 of ADFFSFiler if using RiscOS 4.39, not sure if same applies to RiscOS 4.02.

Here's the link to the download of ADFFSFiler v2.73.

Re: ADFFS freezing after updates

Posted: Thu Jun 25, 2020 9:06 pm
by sirbod
ADFFS does a lot of things when it starts up, but reinitialising ADFS is the very last thing.

Try loading ADFFS after a SHIFT-BREAK, just to make sure it loads without !Boot running, then you'll have to start pulling files out of !Boot until you figure out which one ADFFS doesn't play well with.

I'd start by pulling all the files from PostDesk, then any sound Modules being loaded during the boot sequence.

Re: ADFFS freezing after updates

Posted: Thu Oct 22, 2020 1:43 am
by soviet
Took me a wile but after booting holding shift so no extensions are loaded, the same happen after running adffs the system will freeze :(
Other software seem to run perfectly fine, but adffs don't want to work.
Also updated everything again using the package manager and adffs to 2.73.
Btu the same issue....
Completely stuck here, hope i don't have to format and loose all i have configured.

Re: ADFFS freezing after updates

Posted: Mon Nov 02, 2020 9:04 pm
by sirbod
I actually told you incorrect information previously. On RISC OS 4, it's ADFFS400 you need to load. Could you please try loading that after a SHIFT-BOOT, from the Supervisor prompt and see if it still hangs after the floppy reinitialised.

Do you have any hardware attached that might complain if ADFS is reinitialised?