Image sizes

feedback, comments and suggestions pertaining to the *. forums
dp11
Posts: 841
Joined: Sun Aug 12, 2012 8:47 pm
Contact:

Re: Image sizes

Post by dp11 » Sun May 27, 2018 8:57 am

broken for my too , sorry :(

User avatar
danielj
Posts: 6648
Joined: Thu Oct 02, 2008 4:51 pm
Location: Manchester
Contact:

Re: Image sizes

Post by danielj » Sun May 27, 2018 9:00 am

Can you post a picture of it being broken? (and can you see what the link is for the image and post that too?

d.

User avatar
danielj
Posts: 6648
Joined: Thu Oct 02, 2008 4:51 pm
Location: Manchester
Contact:

Re: Image sizes

Post by danielj » Sun May 27, 2018 9:06 am

OK - the issue is probably that you're suppressing mixed ssl/http requests and tricky had linked the image via http - I've changed that to https now, so you should see it. If you're set up like that you'll probably find that many externally linked images on the forum won't work - it's something you'll have to change on your end.

d.

dp11
Posts: 841
Joined: Sun Aug 12, 2012 8:47 pm
Contact:

Re: Image sizes

Post by dp11 » Sun May 27, 2018 9:18 am

Still no luck for me :(
brokenimage.PNG

User avatar
danielj
Posts: 6648
Joined: Thu Oct 02, 2008 4:51 pm
Location: Manchester
Contact:

Re: Image sizes

Post by danielj » Sun May 27, 2018 9:28 am

Browser? I think it's your end alas, it's fine on my phone and computer, even after forcing reloads?

d.

dp11
Posts: 841
Joined: Sun Aug 12, 2012 8:47 pm
Contact:

Re: Image sizes

Post by dp11 » Sun May 27, 2018 9:35 am

I'm using chrome on computer and phone. I've just tried IE on computer too and I don't get the image :(

The url appears to be :

Code: Select all

 https://stardot.org.uk/forums/download/file.php?id=37787&mode=view 
The the webpage the comes back says "
The selected attachment does not exist anymore."

User avatar
danielj
Posts: 6648
Joined: Thu Oct 02, 2008 4:51 pm
Location: Manchester
Contact:

Re: Image sizes

Post by danielj » Sun May 27, 2018 9:49 am

download/file.php?id=37787&mode=view
Works for me - even after wiping my cache?

dp11
Posts: 841
Joined: Sun Aug 12, 2012 8:47 pm
Contact:

Re: Image sizes

Post by dp11 » Sun May 27, 2018 9:51 am

Doesn't work for me . Some sort of permission thing ?

User avatar
BigEd
Posts: 2140
Joined: Sun Jan 24, 2010 10:24 am
Location: West
Contact:

Re: Image sizes

Post by BigEd » Sun May 27, 2018 9:58 am

Feels like permissions. Danielj, can you have a look in a logged-out state?

User avatar
ctr
Posts: 183
Joined: Wed Jul 16, 2014 2:53 pm
Contact:

Re: Image sizes

Post by ctr » Sun May 27, 2018 10:01 am

I can't see the image either, whether logged in or out. If I use wget I get a straight 404 not found.

Is it expecting a cookie to say you've accepted cookies? I've somehow avoided accepting the cookie permission thing.

Edit: This is unlikely to be the problem. Other images work OK. It's just this one.
Last edited by ctr on Sun May 27, 2018 10:05 am, edited 1 time in total.

User avatar
sydney
Posts: 2249
Joined: Wed May 18, 2005 9:09 am
Location: Newcastle upon Tyne
Contact:

Re: Image sizes

Post by sydney » Sun May 27, 2018 10:01 am

I can see the image both logged in and logged out.

User avatar
sydney
Posts: 2249
Joined: Wed May 18, 2005 9:09 am
Location: Newcastle upon Tyne
Contact:

Re: Image sizes

Post by sydney » Sun May 27, 2018 10:05 am

I just 'tested user permissions' as BigEd and I could see the image.

User avatar
BigEd
Posts: 2140
Joined: Sun Jan 24, 2010 10:24 am
Location: West
Contact:

Re: Image sizes

Post by BigEd » Sun May 27, 2018 10:19 am

Very odd. I've tried three browsers. I checked some other recent posts and the images are OK but of course they might be different in some way.
viewtopic.php?p=204017#p204017

I notice tricky mentions using PNG format.

User avatar
Elminster
Posts: 3137
Joined: Wed Jun 20, 2012 8:09 am
Location: Essex, UK
Contact:

Re: Image sizes

Post by Elminster » Sun May 27, 2018 10:22 am

Seems to be that one image. I can see everything except that one image. Cant see it on Mac in Firefox or ipad in Safari. And I accepted everything yesterday.

User avatar
Elminster
Posts: 3137
Joined: Wed Jun 20, 2012 8:09 am
Location: Essex, UK
Contact:

Re: Image sizes

Post by Elminster » Sun May 27, 2018 10:25 am

Code: Select all

Still, I sneaked off and tidied up what I was doing at Revival:<br>
<img src="https://stardot.org.uk/forums/download/file.php?id=37787&amp;mode=view" class="postimage" alt="Image"><br>
(double size, but only 3K as a .PNG)<br>
If I manaully put in the URL

download/file.php?id=37787&amp;mode=view

I get:

Information

The selected attachment does not exist anymore.

User avatar
Elminster
Posts: 3137
Joined: Wed Jun 20, 2012 8:09 am
Location: Essex, UK
Contact:

Re: Image sizes

Post by Elminster » Sun May 27, 2018 10:29 am

Same error on Mac on Safari and Chrome. Never used Chrome on stardot before (I use it for flash sites only).

Tried logged in and logged out. Same.

Tested with and without 'accepting' cookies message.

User avatar
danielj
Posts: 6648
Joined: Thu Oct 02, 2008 4:51 pm
Location: Manchester
Contact:

Re: Image sizes

Post by danielj » Sun May 27, 2018 10:48 am

How about now?

Basically the file had been uploaded, attached to the post, then deleted and included as an image - whilst this is a tidy way of showing an image, it means that the attachment gets orphaned in phpBB and it's possible that displaying orphaned images is somewhat unpredictable...

User avatar
BigEd
Posts: 2140
Joined: Sun Jan 24, 2010 10:24 am
Location: West
Contact:

Re: Image sizes

Post by BigEd » Sun May 27, 2018 10:57 am

That's fixed it! I think that might be a trick which tricky does quite a bit- perhaps it's now a trick too far? This slightly earlier post does the same, I think:
viewtopic.php?p=203040#p203040

User avatar
danielj
Posts: 6648
Joined: Thu Oct 02, 2008 4:51 pm
Location: Manchester
Contact:

Re: Image sizes

Post by danielj » Sun May 27, 2018 10:59 am

Yup - basically I think phpBB doesn't like it - add to that, we do delete orphaned files...

d.

User avatar
BigEd
Posts: 2140
Joined: Sun Jan 24, 2010 10:24 am
Location: West
Contact:

Re: Image sizes

Post by BigEd » Sun May 27, 2018 11:00 am

Hmm, is there any way to check whether embedded images have been recently reaped? Or how many?

User avatar
danielj
Posts: 6648
Joined: Thu Oct 02, 2008 4:51 pm
Location: Manchester
Contact:

Re: Image sizes

Post by danielj » Sun May 27, 2018 11:06 am

Not really - we hit a point where we had several gigabytes of orphaned files. so we tend just to scrub them - it's usually when people have started posts, added attachments and stopped before submitting or else deleted the post. There's no way of telling which post an orphan should belong to. (I just zapped about 30, most of which were me testing things).

d.

User avatar
tricky
Posts: 2849
Joined: Tue Jun 21, 2011 8:25 am
Contact:

Re: Image sizes

Post by tricky » Sun May 27, 2018 11:13 am

I do sometimes linked to an attached file if it doesn't display, but never delete the attachment. It does look like the attached image has disappeared of scramble, but not by me, maybe before the two attachment fix.

User avatar
BigEd
Posts: 2140
Joined: Sun Jan 24, 2010 10:24 am
Location: West
Contact:

Re: Image sizes

Post by BigEd » Sun May 27, 2018 11:16 am

ah, the multi-attachment bug - that would explain it. And should mean that reaping files is generally not going to be problematic. Phew!

User avatar
danielj
Posts: 6648
Joined: Thu Oct 02, 2008 4:51 pm
Location: Manchester
Contact:

Re: Image sizes

Post by danielj » Sun May 27, 2018 11:21 am

It could well have been that - I suspect we're OK now if that was the case.

d.

User avatar
1024MAK
Posts: 8000
Joined: Mon Apr 18, 2011 4:46 pm
Location: Looking forward to summer in Somerset, UK...
Contact:

Re: Image sizes

Post by 1024MAK » Sun May 27, 2018 3:31 pm

Each member can see the attachments they have by going to their user control panel, there, there is a menu item "manage attachments".

I don't know if orphaned files would show up here though.

Mark

User avatar
hoglet
Posts: 7600
Joined: Sat Oct 13, 2012 6:21 pm
Location: Bristol
Contact:

Re: Image sizes

Post by hoglet » Sun May 27, 2018 3:44 pm

1683 attachments :shock:

User avatar
jgharston
Posts: 3248
Joined: Thu Sep 24, 2009 11:22 am
Location: Whitby/Sheffield
Contact:

Re: Image sizes

Post by jgharston » Mon May 28, 2018 12:10 am

I've been trying to get https working on mdfs.net, but something's not right as it comes up with "insecure site: self-signed certificate". At some point I/somebody/gremlins killed uploading images to the Wiki, and I've been prioritising that at the moment.

Code: Select all

$ bbcbasic
PDP11 BBC BASIC IV Version 0.25
(C) Copyright J.G.Harston 1989,2005-2015
>_

User avatar
danielj
Posts: 6648
Joined: Thu Oct 02, 2008 4:51 pm
Location: Manchester
Contact:

Re: Image sizes

Post by danielj » Mon May 28, 2018 5:23 am

You have to use a cert from an external provider, eg. Let's encrypt (which is free). It sort of proves the server with the cert is the server that requested the cert (but not who that actually is), and allows encrypted comms.

d.

User avatar
Elminster
Posts: 3137
Joined: Wed Jun 20, 2012 8:09 am
Location: Essex, UK
Contact:

Re: Image sizes

Post by Elminster » Mon May 28, 2018 9:19 am

As Daniel says, over the last few years there has been a lot of tightening up on https, I.e. force tls 1.2, and the move away from allowing self signed certificates. Java is a particular pain. Were as development system you used to use self signed and only real ones on prod, you now have them everywhere, to stop the winging messages.

User avatar
CMcDougall
Posts: 6301
Joined: Wed Feb 02, 2005 3:13 pm
Location: Shadow in a Valley of Scotland
Contact:

Re: Image sizes

Post by CMcDougall » Mon May 28, 2018 8:53 pm

viewtopic.php?f=45&t=13893
^ some of the pic's in this thread have gone pear shaped, on my mobby anyways, not checked lappy....
Only noticed as someone on ebay from France wanted a copy of my roms!

EDIT: just used that link straight into browser (still on mobby) & now they show proper :?
ImageImageImage

Post Reply