Commodore CBM 3008 - Blank Screen

Talk about non-Acorn classic computers/hardware/software here (including retro consoles)
Post Reply
Krysiz
Posts: 1
Joined: Fri Mar 09, 2018 11:21 am
Contact:

Commodore CBM 3008 - Blank Screen

Post by Krysiz » Fri Mar 09, 2018 12:22 pm

Hopefully, there are some PET experts in here. I've been trying to restore my CBM 3008 which is in incredible condition, however, the screen briefly shows the garbled image then goes blank. The computer is still running and you can still hear the monitor. I've so far tried the following:

* Pressing return just in case the text is off the top of the screen - still doesn't display
* re-seating all the socketed chips
* re-capped the power side of the board
* changed the Voltage Regulator

I've done some quick volt checking on some of the chips and I've marked two with red dots that have strange readings. The top left one shows 0 volts and the one underneath shows 2V where all the other are 4.8V

Does anyone have any other ideas?

Kind Regards
Matt
Attachments
PET.jpg

Prime
Posts: 2601
Joined: Sun May 31, 2009 11:52 pm
Contact:

Re: Commodore CBM 3008 - Blank Screen

Post by Prime » Fri Mar 09, 2018 2:31 pm

What are the two chips with the "strange" readings? As it may be that they have their power pins somewhere other than the corners.

Worth checking the voltages on the 4108 RAM chips as well. They are effectively half good 4116s so also require +5V, +12V and -5V on the same pins. If you do get it working it's a reasonably easy swap to remove the 4108 chips and replace them with 4116s for 16K, if you also fill the other bank of chips to you can take the machine up to 32K....assuming you can get it working first :)

Cheers.

Phill.

Ezzio
Posts: 4
Joined: Tue Mar 13, 2018 11:15 pm
Contact:

Re: Commodore CBM 3008 - Blank Screen

Post by Ezzio » Wed Mar 14, 2018 10:07 am

Can you post a picture of the garbled screen? Sounds like a bad ROM. Shouldn't be too hard to fix.

Post Reply