Napoleon - Molimerx Ltd 1983 tape rip

want to contribute an update to the archive? post it here!
Post Reply
User avatar
CMcDougall
Posts: 6402
Joined: Wed Feb 02, 2005 3:13 pm
Location: Shadow in a Valley of Scotland
Contact:

Napoleon - Molimerx Ltd 1983 tape rip

Post by CMcDougall » Wed Nov 30, 2016 8:43 pm

Napoleon - Molimerx Ltd 1983 tape rip:
NapoleanBBC-Molimerx Ltd1983.jpg
media
Courtesy of Wim :wink: & after about 15 PMs to him, then Kees also helping again to get to MMC /SSD,

I put it back to tape, as it now seems to work...ish :?
napL2.png
main part
so below is a .UEF & not working .SSD

to get tape UEF to work, I done :
*T.
*L."" B00
PAGE=&2800
RUN
so must be another first part /ldr missing /can't be read / or tape inlay instructions
Attachments
Napolean-Molimerx Ltd1983.zip
uef
(12.09 KiB) Downloaded 63 times
NapoleanBBC-Molimerx Ltd1983.zip
ssd
(8.17 KiB) Downloaded 60 times
ImageImageImage

User avatar
oss003
Posts: 2825
Joined: Tue Jul 14, 2009 11:57 am
Location: Netherlands
Contact:

Re: Napoleon - Molimerx Ltd 1983 tape rip

Post by oss003 » Wed Nov 30, 2016 10:56 pm

Hmmmm .... this was what the program did after trying to run it and then pressing BREAK
Maybe BREAK is redefined?

Greetings
Kees

User avatar
oss003
Posts: 2825
Joined: Tue Jul 14, 2009 11:57 am
Location: Netherlands
Contact:

Re: Napoleon - Molimerx Ltd 1983 tape rip

Post by oss003 » Thu Dec 01, 2016 10:45 am

Colin, when driving home yesterday I was thinking about the NAPOLEON program.
I wonder if the program is ok.
First I loaded NAPOLEON at &2000 and then saved it from &2000+&6200 ......... but that's above the &8000 area.
The last &0200 bytes are not correct in my opinion.

The same for the second file NAPOLEON-MAIN.

Maybe Wim should repeat the saving but with loading it at eg. &1C00

Greetings
Kees

User avatar
lurkio
Posts: 1865
Joined: Tue Apr 09, 2013 11:30 pm
Location: Doomawangara
Contact:

Re: Napoleon - Molimerx Ltd 1983 tape rip

Post by lurkio » Thu Dec 01, 2016 12:40 pm

Ignore me if you've already been over this, but can't Wim (or whoever currently has the tape) capture the audio off the tape and then possibly get that converted to a CSW or UEF image?

Then we'd have the data in a format that would be closer to the original source.

:?:

User avatar
leenew
Posts: 3766
Joined: Wed Jul 04, 2012 3:27 pm
Location: Doncaster, Yorkshire
Contact:

Re: Napoleon - Molimerx Ltd 1983 tape rip

Post by leenew » Thu Dec 01, 2016 3:59 pm

This is on the MIA list...
Would it not be better to send the original tape to Col?
I'm sure he would like an early Christmas present :D
Lee

User avatar
CMcDougall
Posts: 6402
Joined: Wed Feb 02, 2005 3:13 pm
Location: Shadow in a Valley of Scotland
Contact:

Re: Napoleon - Molimerx Ltd 1983 tape rip

Post by CMcDougall » Thu Dec 01, 2016 5:32 pm

^owww Yes.... #-o , knew it was MIA as Wim asked 8)

Kees, it's ok, as &2000 +&2800 ( longest part) =&4800, so below &7C00 (on Mode7 scn) :wink:
ImageImageImage

User avatar
billcarr2005
Posts: 1263
Joined: Fri Sep 09, 2005 3:01 pm
Location: UK
Contact:

Re: Napoleon - Molimerx Ltd 1983 tape rip

Post by billcarr2005 » Thu Dec 01, 2016 6:05 pm

The map was being relocated from &E00 to &5800 for &1900 using code at &D20. I've moved it to &3E00 so it occupies to &5700, then there's the small piece of relocation code from &D20 at &5700. When "Initialising" approximately &700 bytes are taken up immediately after the BASIC program, this might increase as the game progresses...
Loading it at &1100 the TOP is &34EE, so it gives &912 bytes until the map data is overwritten.
Failing that, the relocation code & map could be put back in their original positions after *TAPE has been issued.
Attachments
NapoleanBBC-Molimerx Ltd1983.zip
(7.77 KiB) Downloaded 72 times

User avatar
lurkio
Posts: 1865
Joined: Tue Apr 09, 2013 11:30 pm
Location: Doomawangara
Contact:

Re: Napoleon - Molimerx Ltd 1983 tape rip

Post by lurkio » Thu Dec 01, 2016 6:29 pm

Thanks, BillC. =D>

As this game was MIA, it would still be nice to have a faithful image of the original tape, even if it's a WAV or MP3.

:?:

User avatar
Multiwizard
Posts: 1454
Joined: Wed Jan 11, 2012 9:03 pm
Contact:

Re: Napoleon - Molimerx Ltd 1983 tape rip

Post by Multiwizard » Fri Dec 02, 2016 7:59 am

Hi,

I just found this topic,, thanks Colin... :^o :lol:

Here is a hard copy of the tape.

It's from tape right into my digital voice recorder:

http://www.onedirect.es/media/catalog/p ... -ws100.jpg


Greetings, Wim... :-)
Attachments
WS_10013.zip
(1.1 MiB) Downloaded 70 times

User avatar
CMcDougall
Posts: 6402
Joined: Wed Feb 02, 2005 3:13 pm
Location: Shadow in a Valley of Scotland
Contact:

Re: Napoleon - Molimerx Ltd 1983 tape rip

Post by CMcDougall » Fri Dec 02, 2016 8:28 pm

^just checked your .WMA file (crap M$oft own rubbish format), and does still have just the two files.
It won't convert to .UEF /.CSW (after converting to .RAW / .WAV ), but who actually cares, as I've done already :roll:

maybe ultra rare, because it Never worked BITD :lol:

unless some instructions /tape cover turns up*, with more than CH."" to load.....

did notice, when I done on a Tape only beeb emulator :
*L.""
then press Break, I get:
PAGE=&2800
OLD
!&E00=0
>_
then typed RUN, it worked perfectly fine with no 'junk' on map :D

*so that may have been on the original tape cover /inlay \:D/
ImageImageImage

User avatar
lurkio
Posts: 1865
Joined: Tue Apr 09, 2013 11:30 pm
Location: Doomawangara
Contact:

Re: Napoleon - Molimerx Ltd 1983 tape rip

Post by lurkio » Sun Dec 04, 2016 12:15 pm

CMcDougall wrote:^just checked your .WMA file ... and does still have just the two files ... won't convert to .UEF /.CSW ... but who actually cares, as I've done already ... maybe ultra rare, because it Never worked BITD ... unless some instructions /tape cover turns up*, with more than CH."" to load..... did notice, when I done on a Tape only beeb emulator : *L."" // then press Break, I get: // PAGE=&2800 // OLD // !&E00=0 ... then typed RUN, it worked perfectly fine with no 'junk' on map ... *so that may have been on the original tape cover /inlay
Thanks, Wim and Col. I haven't checked the .WMA file yet, but if, as you say, Col, it contains the same two files that you uploaded earlier, and if those were the actual loading instructions, then wow, what a weird way to release a tape commercially!

:shock:
Last edited by lurkio on Mon Dec 05, 2016 3:33 pm, edited 1 time in total.

User avatar
Multiwizard
Posts: 1454
Joined: Wed Jan 11, 2012 9:03 pm
Contact:

Re: Napoleon - Molimerx Ltd 1983 tape rip

Post by Multiwizard » Sun Dec 04, 2016 12:27 pm

Hi,

the B side has the same files on it... :?


Greetings, Wim... :-)
Attachments
P1180256 Small Duplicate.JPG

User avatar
PitfallJones
Posts: 434
Joined: Fri Feb 22, 2008 3:44 pm
Contact:

Re: Napoleon - Molimerx Ltd 1983 tape rip

Post by PitfallJones » Sun Dec 04, 2016 11:40 pm

Hi There,

I tried your dump but unfortunately it didn't work too well - perhaps the rate you recorded it at - i.e 32kps is slightly insufficient. Perhaps you could record it at 320kps instead?

(Actually I don't think I've ever seen that rate for an audio file - even back in the early days of the 2000s!)

PJ

User avatar
Multiwizard
Posts: 1454
Joined: Wed Jan 11, 2012 9:03 pm
Contact:

Re: Napoleon - Molimerx Ltd 1983 tape rip

Post by Multiwizard » Mon Dec 05, 2016 7:03 am

PitfallJones wrote:Hi There,

I tried your dump but unfortunately it didn't work too well - perhaps the rate you recorded it at - i.e 32kps is slightly insufficient. Perhaps you could record it at 320kps instead?

(Actually I don't think I've ever seen that rate for an audio file - even back in the early days of the 2000s!)

PJ
Hi,

I played the tape with a:

https://i.ebayimg.com/00/s/NzY4WDEwMjQ= ... i/$_86.JPG

right into my:

http://www.onedirect.es/media/catalog/p ... -ws100.jpg

My Olympus don't has a adjustable recording rate... 8)


Greetings, Wim... :-)

User avatar
PitfallJones
Posts: 434
Joined: Fri Feb 22, 2008 3:44 pm
Contact:

Re: Napoleon - Molimerx Ltd 1983 tape rip

Post by PitfallJones » Mon Dec 05, 2016 10:57 am

Hi Wim,

Neat little device!

Actually according to the manual it can record in LP,SP and HQ modes - I'm gussing you have it in LP mode with only does 100-2,000 Hz.
The letters of the current mode appear on the screen.

Here is the manual:
WS-100_WS-200S_Instructions_EN.pdf
(510.99 KiB) Downloaded 51 times
and specs:
http://www.olympusamerica.com/cpg_secti ... id=1170#12

To change the recording quality you can press and hold the menu button for 1 second and select the mode menu.

PJ

User avatar
CMcDougall
Posts: 6402
Joined: Wed Feb 02, 2005 3:13 pm
Location: Shadow in a Valley of Scotland
Contact:

Re: Napoleon - Molimerx Ltd 1983 tape rip

Post by CMcDougall » Mon Dec 05, 2016 5:08 pm

^still pointless, I've done! #-o

No sneaky loaders, just two files with normal gap of 3 seconds of blank between 1st lead out & 2nd lead in.

320 is well overkill, 96 works with my .WAVs to MP3 with some older Lame's, not the newer :shock:
ImageImageImage

User avatar
Multiwizard
Posts: 1454
Joined: Wed Jan 11, 2012 9:03 pm
Contact:

Re: Napoleon - Molimerx Ltd 1983 tape rip

Post by Multiwizard » Mon Dec 05, 2016 6:27 pm

PitfallJones wrote:Hi Wim,

Neat little device!

Actually according to the manual it can record in LP,SP and HQ modes - I'm gussing you have it in LP mode with only does 100-2,000 Hz.
Hi,

I did record it in HQ mode, I always use the HQ mode... 8)


Greetings, Wim... :-)
Attachments
P1180263 Small HQ Mode.JPG

Post Reply