Strange hdf creation in VRPC

ask about 32-bit emulators like ArcEm, Red Squirrel, Arculator or RPCEmu here
Post Reply
Posts: 210
Joined: Sat Oct 24, 2015 8:25 am
Location: Sunny Wigan

Strange hdf creation in VRPC

Post by Boydie » Fri Mar 02, 2018 7:55 pm

I've been playing around with creating ide drive .hdf images in VirtualRPC for some time. I'd always assumed that 2Gb was the largest image I could create because that's all I'd been successful with in the past.

Today, I tried again to create a 3Gb drive (6144 63 16 512). It worked fine, and formatted okay, and gave a 3Gb-ish .hdf file in the correct folder. So I tried again for a 4Gb drive (8192 63 16 512). That worked fine as well, and gave a 4Gb-ish hdf file. So everything seemed peachy.

It all worked fine, but then I tried again and started getting broken directory errors. When I checked the .hdf file, I found it to be 2Gb instead of the expected 4Gb. Now, 4096 63 16 512 gives a 2Gb drive and 2Gb file. Anything more than that now results in a .hdf file half the expected size. eg 6144 formats under !Hform to 3Gb but yields a 1.5Gb file, 5120 formats to what riscos claims is 2.5Gb but only gives a 1.25Gb file.

Any idea what's going on? I've changed literally nothing between it working and it stopping working.

Post Reply