Issue 6 ELK - White Screen

discuss both original and modern hardware for the bbc micro/electron
Post Reply
User avatar
bagpuss22
Posts: 63
Joined: Tue Feb 19, 2013 3:18 pm
Location: East Sussex
Contact:

Issue 6 ELK - White Screen

Post by bagpuss22 »

Gents,

I have a lovely Issue 6 with the standard white screen.

I have replaced the TM4164EC module but to no avail :(

I assume that the issue could now be the ULA, soldered in blob!?

Any thoughts on other things to check or where I could find a replacement ULA?

Cheers

Russ
stuslayer
Posts: 142
Joined: Thu Feb 28, 2019 6:17 pm
Location: Kellington, North Yorkshire
Contact:

Re: Issue 6 ELK - White Screen

Post by stuslayer »

Dave Hitchins would probably be a good source of info, it's my (limited) understanding that it's rare for Issue 6 ULA's to go bad, but more knowledgeable people will give you a more definitive answer.
User avatar
danielj
Posts: 8592
Joined: Thu Oct 02, 2008 5:51 pm
Location: Manchester
Contact:

Re: Issue 6 ELK - White Screen

Post by danielj »

It's more likely to be the processor or the ROM than the ULA I'd have thought in this instance. Do you have any way of checking signals?

d.
User avatar
CMcDougall
Posts: 7048
Joined: Wed Feb 02, 2005 3:13 pm
Location: Shadow in a Valley of Scotland
Contact:

Re: Issue 6 ELK - White Screen

Post by CMcDougall »

weird, usually always the 4x 8k ram :?
Was in mine , after checking 6502 & 32k rom :x
Attachments
21950915_10155225199372730_2559398444274016656_o.jpg
ImageImageImage
User avatar
bagpuss22
Posts: 63
Joined: Tue Feb 19, 2013 3:18 pm
Location: East Sussex
Contact:

Re: Issue 6 ELK - White Screen

Post by bagpuss22 »

HI all,

No access to other kit apart from a DVM which will do frequency....

The RAM is a single TM4164EC and I have replaced that with a new one.

Can ROM or CPU cause a white screen?
User avatar
CMcDougall
Posts: 7048
Joined: Wed Feb 02, 2005 3:13 pm
Location: Shadow in a Valley of Scotland
Contact:

Re: Issue 6 ELK - White Screen

Post by CMcDougall »

the 32k rom can, as that's how I fixed my cousin's one BITD

not had a faulty 6502, but someone recently posted a thread, & found it was that, so can do too
ImageImageImage
User avatar
bagpuss22
Posts: 63
Joined: Tue Feb 19, 2013 3:18 pm
Location: East Sussex
Contact:

Re: Issue 6 ELK - White Screen

Post by bagpuss22 »

I am hoping it's not the ULA as I probably cannot source one.

As for 6502 then I have a few and ROMs can be replaced.

OK where to start really..... :D
User avatar
daveejhitchins
Posts: 6221
Joined: Wed Jun 13, 2012 6:23 pm
Location: Newton Aycliffe, County Durham
Contact:

Re: Issue 6 ELK - White Screen

Post by daveejhitchins »

bagpuss22 wrote:
Fri May 29, 2020 11:31 pm
I am hoping it's not the ULA as I probably cannot source one.

As for 6502 then I have a few and ROMs can be replaced.

OK where to start really..... :D
I've only ever seen 1 issue 6 ULA failure, but that doesn't mean there can't be others! Definitely try the ROM and processor first. I also recomend going through the service manual fault finding guide as well.

Unfortunately, until the UEU is ready (or just a FPGA replacement) I won't have any ULAs spare :?

Good luck. Keep us updated on your progress . . .

Dave H :D
User avatar
bagpuss22
Posts: 63
Joined: Tue Feb 19, 2013 3:18 pm
Location: East Sussex
Contact:

Re: Issue 6 ELK - White Screen

Post by bagpuss22 »

OK, I have now socketed the ROM and CPU.

Read the ROM content out and compared it to the ROM files and all looks OK.

WIth the original CPU in, with no keyboard connected: FULL WHITE SCREEN.
with keyboard connected: FULL WHITE SCREEN, LED lit or
WHITE HORIZONTAL bars, LED not Lit.

With new R65C02P3 in, with no keyboard connected: WHITE HORIZONTAL bars briefly then black screen, sometimes with a few flashing pixels.
with keyboard connected: WHITE HORIZONTAL bars briefly then black screen, sometimes with a few flashing pixels. LED lit

PS the Pixels are the same each time...

Image
Last edited by bagpuss22 on Sat May 30, 2020 6:15 pm, edited 1 time in total.
Kazzie
Posts: 1793
Joined: Sun Oct 15, 2017 8:10 pm
Location: North Wales
Contact:

Re: Issue 6 ELK - White Screen

Post by Kazzie »

Hm, ROM RAM and CPU swapped out... have you checked the clock and reset signals for the CPU?
BBC Model B 32K issue 7, Sidewise ROM board with 16K RAM
Archimedes 420/1 upgraded to 4MB RAM, ZIDEFS with 512MB CF card
RiscPC 600 under repair
Acorn System 1 home-made replica
User avatar
bagpuss22
Posts: 63
Joined: Tue Feb 19, 2013 3:18 pm
Location: East Sussex
Contact:

Re: Issue 6 ELK - White Screen

Post by bagpuss22 »

Think that is my next port of call..........
Post Reply

Return to “8-bit acorn hardware”