Page 1 of 1

!KMSwitch errors on RISC PC 4.02 (soft)

Posted: Fri Oct 13, 2017 3:00 pm
by Trapper
Any idea what this SWI is and if I can softload it?

Trying to run !KMSwitch on my RISC PC running 4.02 softload (3.70 in ROM) and I get the following error. I can load the RMModule and configure the server that way, but it’s still not working correctly.
My Pi can see the RISC PC (running as server), but when it connects my RPC mouse stops working, but the Pi one still does. I assume there is some config missing. I’ve also noticed that on the RISC PC the Pi’s hostname is just garbled.
Any idea what module has the SWI that is stopping it from running, and if I can softload it?

Could I run the !KMSwitch server from either Virtual Acorn (VirtualA5000, VirtualRPC, or even my licensed copy of VirtualRPC-AdjustSA) or from a network configured rpc_Emu?

Has anyone given this a try?

I’m still having problems updating my Pi instal

Re: !KMSwitch errors on RISC PC 4.02 (soft)

Posted: Fri Oct 13, 2017 3:28 pm
by crj
If you're searching for SWIs, it can help to search for the base of the range, not the particular number, so &44EC0 in this case.

Google found me this page, which says it's Toolbox_Initialise .