A4 Laptop - replacement electrolytic capacitors and CMOS battery

discuss the archimedes & risc pc, peripherals and risc os/risc os on pi
Post Reply
philpem
Posts: 349
Joined: Fri Apr 04, 2014 6:42 pm
Contact:

A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by philpem » Wed Sep 18, 2019 3:40 am

I'm currently repairing an A4 which is currently dead. I have 20V on the DC-DC converter, but the BMU never pulls POWER_ON low to enable the DC-DC converter. The BMU has 5V power, so I suspect I'm looking at a failure in the BMU reset circuitry or clock.

But before I fix that, there's a bigger problem -- the electrolytic capacitors on the PCB have started to leak. Apparently this is a bit of an "A4 thing". There are dots of corrosion all over the board and I'd be a fool to dismiss the possibility that it could be part of the BMU issue.

Does anyone have a list of the SMD electrolytic capacitors on the A4 motherboard -- ideally with part numbers of suitable replacements?
(I'm sure there was a thread about 'extreme A4 repair' involving recapping, PCB cleaning and such, but I'll be darned if I can find it)

I'm also wondering if anyone knows of a suitable substitute for the CMOS battery -- otherwise I expect I can squeeze a NiMH coin cell into the gap between the battery bay and the floppy drive. I've had a look in the RS catalogue but there doesn't seem to be anything particularly suitable (at least anything tagged).

Cheers,
Phil.


philpem
Posts: 349
Joined: Fri Apr 04, 2014 6:42 pm
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by philpem » Wed Sep 18, 2019 6:58 pm

davidb wrote:
Wed Sep 18, 2019 10:44 am
Have you seen theom's Acorn A4 pages?
I have - his guide is how I got the thing apart!

RobC
Posts: 2882
Joined: Sat Sep 01, 2007 10:41 pm
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by RobC » Wed Sep 18, 2019 7:14 pm

The schematics are in the technical drawings and the parts list is in the technical reference manual here.

I'd definitely recap the board if you can but working on the A4 is a pain - I damaged the keyboard connectors on mine just by opening them up to remove the keyboard. Also, the conductive material on the end of the keyboard cable comes off very easily.

The good news is that CJE Micros have a range of pretty reasonably priced spares for the A4.

Ottly
Posts: 152
Joined: Tue Jun 10, 2014 11:34 am
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by Ottly » Thu Sep 19, 2019 1:47 pm

I did this for a friend of mines A4. Recapped the board after one exploded. And replaced the cmos battery.

I can post more details if you’d like them?

Scott.

hubersn
Posts: 177
Joined: Sun Aug 14, 2016 8:59 pm
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by hubersn » Thu Sep 19, 2019 2:52 pm

Ottly wrote:
Thu Sep 19, 2019 1:47 pm
I did this for a friend of mines A4. Recapped the board after one exploded. And replaced the cmos battery.

I can post more details if you’d like them?
I would like all details you can possibly provide, since my A4 also needs a battery replacement.

Thanks
hubersn

philpem
Posts: 349
Joined: Fri Apr 04, 2014 6:42 pm
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by philpem » Wed Sep 25, 2019 1:07 pm

Ottly wrote:
Thu Sep 19, 2019 1:47 pm
I did this for a friend of mines A4. Recapped the board after one exploded. And replaced the cmos battery.

I can post more details if you’d like them?

Scott.
I'd love it if you could.

I'm going to spend the evening measuring up the capacitors on the board and getting some replacements ordered from RS. Sadly the parts list in the TRM doesn't include that nugget of info, only the component values.

Seeing as I don't have the DC-DC power-on signal (but the DC-DC works), I expect I'm dealing with some kind of issue in the BMU support circuitry or a dud solder joint.

philpem
Posts: 349
Joined: Fri Apr 04, 2014 6:42 pm
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by philpem » Fri Sep 27, 2019 10:48 am

Picked up a box of these to recap the A4:

https://www.amazon.co.uk/gp/product/B07NK9SKNJ/

(440-piece SMD electrolytic capacitor kit)

Looks like it has the right sizes and values, and it's cheaper than buying the parts individually from RS...
Expect more updates this weekend!

SteveBagley
Posts: 256
Joined: Sun Mar 15, 2015 8:44 pm
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by SteveBagley » Fri Sep 27, 2019 10:55 am

philpem wrote:
Fri Sep 27, 2019 10:48 am
Picked up a box of these to recap the A4:

https://www.amazon.co.uk/gp/product/B07NK9SKNJ/

(440-piece SMD electrolytic capacitor kit)

Looks like it has the right sizes and values, and it's cheaper than buying the parts individually from RS...
Expect more updates this weekend!
Please take lots of photos! I need to do this with my A4…

Steve

philpem
Posts: 349
Joined: Fri Apr 04, 2014 6:42 pm
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by philpem » Sat Sep 28, 2019 2:38 pm

Quick one while I'm half-way through the repair and taking a break...

This isn't one for the faint of heart.

Getting the capacitors off is a nightmare. Try to desolder them and you find you can't heat the solder because it's now a mix of lead and tin oxides. So you have to take them off in pieces. More or less the 8bitguy's method.
  • Use a fairly sturdy tool to hold down the plastic section of the capacitor.
  • While holding that down, use a pair of needlenose pliers to grab the metal body of the capacitor.
  • Gently rock the capacitor while pulling it vertically upwards and pushing the plastic piece hard against the PCB.
  • If you've done this right, you'll now have two legs sticking up from the board.
One you have access to the two pins, you have two options. Either clean them and heat them with a soldering iron, or (again) push the plastic down and rock the wire from side to side until it breaks. Remove the plastic piece and desolder the leads.

Watch out for the smell of rotten fish.

And finally, when you've got the capacitor off the board, you'll probably find that the PCB pads have either corroded away or have lifted off. So you have to repair those. It's not as hard as repairing a QFP land on a RISC PC, but it's certainly tedious.

And before you repair it, you need to wash off the goo from underneath the capacitors...

More updates shortly!
Attachments
2019-09-27 23.02.23.jpg

philpem
Posts: 349
Joined: Fri Apr 04, 2014 6:42 pm
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by philpem » Sun Sep 29, 2019 11:45 pm

Current state of the A4 motherboard - most of the lifted pads have been replaced with copper tape, now I'm just waiting for the epoxy to set before I fit some new caps.

Probably need to pull the crystal near the DC-IN to check for more corrosion in that area. Most of the stuff energised to 20V+ took a real bad hit when the capacitors leaked. The rest of the board seems more or less unscathed.
Attachments
2019-09-29 23.23.16.jpg

mattdy4
Posts: 86
Joined: Mon Feb 26, 2018 11:18 am
Location: Wolverhampton
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by mattdy4 » Thu Oct 03, 2019 12:19 pm

I recapped my deadish A4 in the spring. I used the TRM to find what capacitor values etc were then tallied up what values I needed to buy in a spreadsheet. Hopefully might save someone a bit of work. Here it is;

10uf 16v (8) - C19 C65 C67 C93 C108 C133 C135 C137
4.7uf 25v (3) - C107 C134 C136
47uf 16v (9) - C13 C38 C55 C57 C62 C66 C78 C89 C138
100uF 6.3v (2) - C61 C97
220uF 4v (1) - C102

Recap didn't fix it but it gets further than it did. A lot of caps had leaked, especially those in a cluster in the bottom right hand side of the board

I used Panasonic caps from Farnell (first part is their stock number). I already had a stock of EEEFK1C470P (47uf 16v) caps. Can confirm that they fit pads as original

1244389 3 3 0 EEEFK0J101AP CAP, 100µF, 6.3V, RADIAL, SMD EEEFK0J101AP
2326083 2 2 0 EEE0GA221SP CAP, 220µF, 4V, RADIAL, SMD EEE0GA221SP
9695648 10 10 0 EEEFK1C100R CAP, 10µF, 16V, RADIAL, SMD EEEFK1C100R
9696822 5 5 0 EEEHB1E4R7R CAP, 4.7µF, 25V, RADIAL, SMD EEEHB1E4R7R

philpem
Posts: 349
Joined: Fri Apr 04, 2014 6:42 pm
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by philpem » Thu Oct 03, 2019 9:24 pm

Cheers for that, Matt!

I finished recapping my A4 last night, then moved onto backing it up onto a Zip disk (easy when the hard drive is only 60MB!).
There's a custom-built ICS Wizzo 3v15 ROM in the 5th column slot and a CompactFlash adapter on the drive tray. Sadly the CF adapter only has one screw hole which lines up with the bracket... :(

It's restoring from the Zip drive now and seems to be fully working aside from the temporary lack of the keyboard and LCD panel. Once I have the NiMH coin cell fitted, I'll be reassembling the machine and posting some final photos.

Meanwhile I've attached another photo of the test rig, and tweeted a couple more: https://twitter.com/philpem/status/1179852496543592454


The reason this A4 wouldn't boot turned out to be capacitor goo underneath the BMU's clock crystal. While the BMU had power and the periodic reset/wakeup tick, it wasn't going to toggle the DC-DC on without the clock signal.
The solution was to remove the crystal, clean the area (and the crystal itself) thoroughly, then re-tin and re-cover the copper where the solder resist flaked off.

I've got another A4 to fix which is in considerably worse shape (physically and electrically), so that might well be my next project.

For the benefit of anyone who wants to stick a CompactFlash card in one of these machines -- I've attached my custom-build Wizzo fifth-column ROM. Flash it into a 27C512, put it in the socket and enjoy!
The ICS formatter app is on Chris's Acorns. I also tried the APDL one from www.riscos.com, but that hangs after asking you to "press any key to continue"... (groan...)


Bonus fact: you can't do a delete-reset using the PS/2 keyboard port. You need to use the internal keyboard. Same goes for all the RISC OS "hold key X on boot" tricks, it seems. That cost me a few minutes of head-scratching while I was trying to figure out what was up with the video output...
Attachments
wizzo_3v15_AcornA4.zip
(17.68 KiB) Downloaded 13 times
2019-10-03 03.48.43.jpg

User avatar
IanS
Posts: 1256
Joined: Mon Aug 31, 2009 7:02 pm
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by IanS » Thu Oct 03, 2019 10:07 pm

philpem wrote:
Thu Oct 03, 2019 9:24 pm
Bonus fact: you can't do a delete-reset using the PS/2 keyboard port. You need to use the internal keyboard. Same goes for all the RISC OS "hold key X on boot" tricks, it seems. That cost me a few minutes of head-scratching while I was trying to figure out what was up with the video output...
Strange, both the keyboard matrix and the PS/2 connector feed into the same 80C51 (IC2), so the IOC shouldn't be able to tell the difference via Kin/Kout. I wonder if it was a dliberate choice by whoever wrote the firmware in the 80C51.

philpem
Posts: 349
Joined: Fri Apr 04, 2014 6:42 pm
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by philpem » Thu Oct 03, 2019 10:32 pm

IanS wrote:
Thu Oct 03, 2019 10:07 pm
philpem wrote:
Thu Oct 03, 2019 9:24 pm
Bonus fact: you can't do a delete-reset using the PS/2 keyboard port. You need to use the internal keyboard. Same goes for all the RISC OS "hold key X on boot" tricks, it seems. That cost me a few minutes of head-scratching while I was trying to figure out what was up with the video output...
Strange, both the keyboard matrix and the PS/2 connector feed into the same 80C51 (IC2), so the IOC shouldn't be able to tell the difference via Kin/Kout. I wonder if it was a dliberate choice by whoever wrote the firmware in the 80C51.
The 80C51 does seem to reset the PS/2 keyboard a couple of times before it finally accepts that it's there. It might be that it can't detect the key-down events during that process -- or that it realises so late that RISC OS has stopped checking for keys being held down and moved on to booting the system.

mattdy4
Posts: 86
Joined: Mon Feb 26, 2018 11:18 am
Location: Wolverhampton
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by mattdy4 » Fri Oct 04, 2019 8:48 pm

philpem wrote:
Thu Oct 03, 2019 10:32 pm
IanS wrote:
Thu Oct 03, 2019 10:07 pm
philpem wrote:
Thu Oct 03, 2019 9:24 pm
Bonus fact: you can't do a delete-reset using the PS/2 keyboard port. You need to use the internal keyboard. Same goes for all the RISC OS "hold key X on boot" tricks, it seems. That cost me a few minutes of head-scratching while I was trying to figure out what was up with the video output...
Strange, both the keyboard matrix and the PS/2 connector feed into the same 80C51 (IC2), so the IOC shouldn't be able to tell the difference via Kin/Kout. I wonder if it was a dliberate choice by whoever wrote the firmware in the 80C51.
The 80C51 does seem to reset the PS/2 keyboard a couple of times before it finally accepts that it's there. It might be that it can't detect the key-down events during that process -- or that it realises so late that RISC OS has stopped checking for keys being held down and moved on to booting the system.
Ah in that case I need to reassemble the thing and do a reset. Fingers crossed it working now at it seems to respond but no video, just sync

philpem
Posts: 349
Joined: Fri Apr 04, 2014 6:42 pm
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by philpem » Sat Oct 05, 2019 9:43 pm

The last few parts for my A4 arrived today -- a 1.2V 80mAh coin cell and some M3 threaded inserts.

The hard drive mounting holes for the A4 are ... strange. They only line up with the drive which came in the machine - nothing else I have will fit. Naturally the CF card adapter falls into this category too.
The solution was to put the CF card adapter alongside the old hard drive and mark out the screw positions. I used a soldering iron to drive in some threaded inserts. They still felt a little loose, so I opened up the adapter and put a bit of Araldite around them to make sure they stayed put. Once that was sorted, the CF card adapter screwed right onto the bracket. You can see the difference in mounting position:
2019-10-05 12.26.38_rot.jpg
Using standard mounting screws
2019-10-05 13.42.18.jpg
With threaded inserts fitted
The problem with the setup in the first photo is, the adapter sits too far to the right and fouls the keyboard pegs when you try to refit it. So something must be done...

If you're lazy, you could probably take a bare-board CF adapter and stick it to the hard drive tray with a sticky-pad.

Backing up the old hard drive was easy as pie using a Zip drive and a copy of PowerZip/ZipFS. Restoring once I had the CF card installed was just as easy, once I found a floppy with a copy of !Scrap on it. (Turns out !Backup will run without System, but absolutely requires a Scrap directory).

The ICS IDE utilities on Chris's Acorns work a treat for this version of Wizzo.

I chucked in a spare Transcend 2GB CF card which gave four 503MB partitions. Needless to say, this filled up the icon bar a bit:
2019-10-05 13.53.49_rot.jpg
But where will my apps go?
The final installation uses two 503MB partitions to save icon bar space.

And here she is after being completely reassembled:
2019-10-05 14.04.01.jpg
Back in one piece
I found a couple of A4-specific tools on the drive -- "!" (some kind of display switcher), A4Extra2, Bat_Power (a battery discharger), Pointer (by Acorn, embiggens the pointer), F12<>F10 and NumScr>F10. I have no idea where these came from! Possibly someone's website or an FTP site way back when.

This leaves one more A4 to fix -- the one which looked like it had fallen off the back of a lorry. I might fix that one too... eventually.

As for this one, the battery seems to be having trouble holding a charge. Hopefully cycling it a few times might wake it up -- if not, I have an IMAX B6 R/C pack charger-discharger which might have the desired effect.

mattdy4
Posts: 86
Joined: Mon Feb 26, 2018 11:18 am
Location: Wolverhampton
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by mattdy4 » Wed Oct 09, 2019 2:56 pm

mattdy4 wrote:
Fri Oct 04, 2019 8:48 pm
philpem wrote:
Thu Oct 03, 2019 10:32 pm
IanS wrote:
Thu Oct 03, 2019 10:07 pm

Strange, both the keyboard matrix and the PS/2 connector feed into the same 80C51 (IC2), so the IOC shouldn't be able to tell the difference via Kin/Kout. I wonder if it was a dliberate choice by whoever wrote the firmware in the 80C51.
The 80C51 does seem to reset the PS/2 keyboard a couple of times before it finally accepts that it's there. It might be that it can't detect the key-down events during that process -- or that it realises so late that RISC OS has stopped checking for keys being held down and moved on to booting the system.
Ah in that case I need to reassemble the thing and do a reset. Fingers crossed it working now at it seems to respond but no video, just sync
Yay! It's working with keyboard and screen attached. No external output though even clearing CMOS with Del, 4, R etc.

Those screen connectors are truly awful though. Managed to lift a couple of the conudctive strips right off while doing a full reassemble. Now I have to wait until tomorrow for the aradite to cure fully :roll:

20191009_115838.jpg
20191009_115936.jpg

philpem
Posts: 349
Joined: Fri Apr 04, 2014 6:42 pm
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by philpem » Wed Oct 09, 2019 4:23 pm

mattdy4 wrote:
Wed Oct 09, 2019 2:56 pm
mattdy4 wrote:
Fri Oct 04, 2019 8:48 pm
philpem wrote:
Thu Oct 03, 2019 10:32 pm


The 80C51 does seem to reset the PS/2 keyboard a couple of times before it finally accepts that it's there. It might be that it can't detect the key-down events during that process -- or that it realises so late that RISC OS has stopped checking for keys being held down and moved on to booting the system.
Ah in that case I need to reassemble the thing and do a reset. Fingers crossed it working now at it seems to respond but no video, just sync
Yay! It's working with keyboard and screen attached. No external output though even clearing CMOS with Del, 4, R etc.

Those screen connectors are truly awful though. Managed to lift a couple of the conudctive strips right off while doing a full reassemble. Now I have to wait until tomorrow for the aradite to cure fully :roll:


20191009_115838.jpg

20191009_115936.jpg
Nice one!

The trick with the keyboard and screen cables is to be very, very gentle -- and make sure they're fully open before trying to remove the cable. Glad you managed to fix it though!

I notice your ROM has a jump wire - that's unusual. What's the part number on the ROM label?

Theo Markettos has an A4 with a part number of 0296,064 -- but all my A4s have 0296,063. I'm very curious if yours has the same ROM, and what the differences between the two might be. I imagine it's either a language variant or some bugfixes.

I'm not sure why you don't have RGB video out, though that does go through the Acorn Video Hybrid on the top left, so you could possibly have issues with that. From memory, if you power on with a monitor connected to the VGA port, the A4 should pick it up and use it over the internal LCD.

If not, another way to switch to the VGA output is to use !Configure (in the Apps folder on the iconbar). Go into Screen and change the Monitor Type from LCD (internal screen) to VGA.

mattdy4
Posts: 86
Joined: Mon Feb 26, 2018 11:18 am
Location: Wolverhampton
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by mattdy4 » Wed Oct 09, 2019 4:51 pm

philpem wrote:
Wed Oct 09, 2019 4:23 pm
mattdy4 wrote:
Wed Oct 09, 2019 2:56 pm
mattdy4 wrote:
Fri Oct 04, 2019 8:48 pm


Ah in that case I need to reassemble the thing and do a reset. Fingers crossed it working now at it seems to respond but no video, just sync
Yay! It's working with keyboard and screen attached. No external output though even clearing CMOS with Del, 4, R etc.

Those screen connectors are truly awful though. Managed to lift a couple of the conudctive strips right off while doing a full reassemble. Now I have to wait until tomorrow for the aradite to cure fully :roll:
Nice one!

The trick with the keyboard and screen cables is to be very, very gentle -- and make sure they're fully open before trying to remove the cable. Glad you managed to fix it though!

I notice your ROM has a jump wire - that's unusual. What's the part number on the ROM label?

Theo Markettos has an A4 with a part number of 0296,064 -- but all my A4s have 0296,063. I'm very curious if yours has the same ROM, and what the differences between the two might be. I imagine it's either a language variant or some bugfixes.

I'm not sure why you don't have RGB video out, though that does go through the Acorn Video Hybrid on the top left, so you could possibly have issues with that. From memory, if you power on with a monitor connected to the VGA port, the A4 should pick it up and use it over the internal LCD.

If not, another way to switch to the VGA output is to use !Configure (in the Apps folder on the iconbar). Go into Screen and change the Monitor Type from LCD (internal screen) to VGA.
Thanks and thanks for the tip!

I was very careful making sure the clips were up, I think the plastic had delaminated slightly allowing the copper strip to lift from the plastic, I think my A4 was kept in someone's damp garage for x years so no big surprise!

Yes it's an 0296,064-01 ROM, not looked into the supplementary ROM much so I'll have a read up

I'll see if I can get it to flick to internal LCD when I put it all back together tomorrow via Configure. If I plug in the VGA cable when switched on I get a white line on screen at the top so I don't think it's a circuit problem as I'm getting a sync signal too so if that won't work I'll try another cable too

Your screen looks very crisp by the way, mine looks very muted in comparison

User avatar
IanS
Posts: 1256
Joined: Mon Aug 31, 2009 7:02 pm
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by IanS » Fri Oct 11, 2019 11:24 pm

philpem wrote:
Thu Oct 03, 2019 10:32 pm
The 80C51 does seem to reset the PS/2 keyboard a couple of times before it finally accepts that it's there. It might be that it can't detect the key-down events during that process -- or that it realises so late that RISC OS has stopped checking for keys being held down and moved on to booting the system.
Interesting, if you look at the circuit diagram for the A5000, they were obviously thinking about fitting an 80C51 and using a PS/2 keyboard connector with a quadrature mouse. You can see the unpopolated pads for the 80C51 on the PCB.

I wonder if they gave up on it because the found they couldn't get the power-on delete function to work?

steve3000
Posts: 2193
Joined: Sun Nov 25, 2012 12:43 am
Contact:

Re: A4 Laptop - replacement electrolytic capacitors and CMOS battery

Post by steve3000 » Sat Oct 12, 2019 12:26 am

IanS wrote:
Fri Oct 11, 2019 11:24 pm
Interesting, if you look at the circuit diagram for the A5000, they were obviously thinking about fitting an 80C51 and using a PS/2 keyboard connector with a quadrature mouse. You can see the unpopolated pads for the 80C51 on the PCB.

I wonder if they gave up on it because the found they couldn't get the power-on delete function to work?
I would have guessed they stripped it out to save cost...

Either way they must have given up fairly early on, since Z's prototype A5000 (serial #21) doesn't have the 80C51 fitted... although it does have a cut-out for a rear mouse port which would have been needed.

See photos here: viewtopic.php?f=16&t=9209

Post Reply

Return to “32-bit acorn hardware”