A440 Long RAM test failure

Arc/RPCs, peripherals, RISCOS operating system & ARM kit eg GP2x, BeagleBoard
Post Reply
User avatar
vectorlight
Posts: 189
Joined: Sun Apr 10, 2016 12:23 pm
Location: UK
Contact:

A440 Long RAM test failure

Post by vectorlight » Sun Mar 18, 2018 1:08 pm

Hi All,

Can anybody explain what a "Long RAM test failure" is? When turning my A440 on it flashes the floppy drive with this fault. When it has finished it continues and boots to the RO 3.1 desktop and seems to work okay. I always thought that any RAM test failure would prevent the machine booting at all? :shock:

I've held down the Del key on bootup to clear the CMOS ram but this doesn't fix it. I assume theres a fault in one of the ram chips. Anybody had this problem before? :D
3D Printing and Acorn A3010 Owner!

User avatar
IanS
Posts: 688
Joined: Mon Aug 31, 2009 6:02 pm
Contact:

Re: A440 Long RAM test failure

Post by IanS » Sun Mar 18, 2018 1:12 pm

I had a similar issue with my R140 (A440 with a different badge)

viewtopic.php?f=16&t=14064

Try a set of test roms, should tell you which chip is faulty (it did for me)

viewtopic.php?f=16&t=12252

User avatar
vectorlight
Posts: 189
Joined: Sun Apr 10, 2016 12:23 pm
Location: UK
Contact:

Re: A440 Long RAM test failure

Post by vectorlight » Sun Mar 18, 2018 1:18 pm

IanS wrote:I had a similar issue with my R140 (A440 with a different badge)

viewtopic.php?f=16&t=14064

Try a set of test roms, should tell you which chip is faulty (it did for me)

viewtopic.php?f=16&t=12252
Thanks! I'll have a read of those :D
3D Printing and Acorn A3010 Owner!

Post Reply