Previously working Acorn A4 won't start

discuss the archimedes & risc pc, peripherals and risc os/risc os on pi
Post Reply
nmk
Posts: 1
Joined: Sun Nov 08, 2020 6:48 pm
Contact:

Previously working Acorn A4 won't start

Post by nmk » Sat Nov 21, 2020 4:47 pm

Hi,

I have three Acorn A4 computers which were all working well about 15 years ago when I put them away in the attic.

A few weeks ago I tried starting them up again, but all three have developed the same fault.

When they are switched on, the keyboard keys stay lit (they don't flash). There are no error codes on the floppy drive. The hard disk powers up, but nothing else happens. After a few seconds the hard disk powers down and then a few seconds later it tries again. The screen doesnt light up, but the leds on the lid do light up.

I took one of them apart to try and work out what is wrong. The CMOS battery is no doubt dead, but it has NOT leaked, and I don't see any obvious sign of blown capacitors. Everything looks visibly good.

I've tried running from all three power adapters (one for each machine) and I've tried supplying 18v directly to the battery compartment using a battery that I dismantled with the diodes inside etc, but I get the exact same issue - disk power cycles and nothing else happens.

I had a spare DC/DC converter that was new and unused, and have tried that, but it has not fixed it.

Given that all three previously working machines have developed the same problem, it strikes me that there must be a simple fix for this - all three machines have the same issue.

I'm hoping that its just one simple component needs replacing and that once this is found, the same fix can be applied to all three machines.

Any advice on where to start?

Thanks
N

philpem
Posts: 591
Joined: Fri Apr 04, 2014 6:42 pm
Contact:

Re: Previously working Acorn A4 won't start

Post by philpem » Sat Nov 21, 2020 5:57 pm

Every one of them will need recapping -- that is to say, every single tin-can surface-mount capacitor on the motherboards will need to be replaced. You'll also need to clean the motherboard very, very well to remove the residual capacitor goo. It's worth replacing the CMOS battery at the same time, just to be safe.

What you're describing is exactly what the last A4 I repaired did. The capacitors seemed okay, but when I removed them, I found pools of liquid or yellow crust underneath.

If, after that, you still can't get the machine to power on -- desolder the crystal for the BMU chip, clean underneath, clean the crystal and insulator, and reinstall. One of mine had capacitor-goo under the BMU crystal. If the BMU isn't running, the main 5V power rail won't come up.

Sadly it's not just "one simple component" - it's every single blasted capacitor on the board.

This isn't unique to A4s, though the close quarters of the board layout means there's a very good chance a leaking cap will kill the machine. Amigas have the same issue, and even some other Acorns. I've seen RISC PCs, A3020s and A4000s with leaking SMD capacitors.

The good news is, if you catch it early, it's fully repairable.

Cheers
Phil.

User avatar
IanJeffray
Posts: 382
Joined: Sat Jun 06, 2020 3:50 pm
Contact:

Re: Previously working Acorn A4 won't start

Post by IanJeffray » Sat Nov 21, 2020 7:40 pm

Ditto everything Phil said. I've resurrected a couple of A4s this year with a full recap and other bits.
More details of A4 fixes in this thread, including the list of caps to swap. Swap ALL of them as a first step.
viewtopic.php?f=16&t=17916

Post Reply

Return to “32-bit acorn hardware”