Page 1 of 1

Greetingsto all.

Posted: Fri Jan 24, 2020 7:37 pm
by aerobaticant
Hi,

I have recently been inspired to resurrect my Acorn machines.
So far I've done PSU capacitor replacements on two BBC Model Bs (one Iss 4, one Iss 7), and a Master 128. and they're all working fine.
I've also got my Atom (Issue 4) up and running but with weird video noise issues.
Next step might be the Archimedes A310 that I bought new in 1989. It hasn't been used for about 12 years, although its monitor is working fine.
Ive also got two Electrons, although one of them has a dead ULA.

Wish me luck!

Re: Greetingsto all.

Posted: Fri Jan 24, 2020 7:41 pm
by Multiwizard
Hi,

welcome to this great Forum... :D


Greetings from my little Dutch Atomic Attic, Wim... :-)

Re: Greetingsto all.

Posted: Fri Jan 24, 2020 8:00 pm
by DutchAcorn
Welcome and good luck! Shout out if you need help.

Re: Greetingsto all.

Posted: Fri Jan 24, 2020 8:10 pm
by davidb
Welcome! :D

Re: Greetingsto all.

Posted: Fri Jan 24, 2020 9:07 pm
by flaxcottage
Welcome. :D

Re: Greetingsto all.

Posted: Fri Jan 24, 2020 9:30 pm
by mr-macrisc
Welcome to the mad house :)

Re: Greetingsto all.

Posted: Sat Jan 25, 2020 8:33 am
by tricky
Hi, welcome, good luck.
Sounds like you will have already done the master and Archie batteries.

Re: Greetings to all.

Posted: Sat Jan 25, 2020 11:38 pm
by aerobaticant
The Atom is a bit of a mess internally. I think it may have originally been a kit version. I've ordered replacement electrolytic caps to see if that helps with noise. But all the RAM appears to work and I've even managed to save and load to/from tape. I'll post pics to the Atom HW area at some point.

Batteries in the Master are now AA via a diode/resistor. :-)

The Archimedes is still awaiting attention!

Re: Greetingsto all.

Posted: Sun Jan 26, 2020 12:17 am
by oss003
Welcome .... and enjoy the forum.

Greetings
Kees

Re: Greetingsto all.

Posted: Sun Jan 26, 2020 8:58 am
by roland
aerobaticant wrote:
Fri Jan 24, 2020 7:37 pm
Hi
Hi, welcome to this forum. Enjoy your visits.
aerobaticant wrote:
Fri Jan 24, 2020 7:37 pm
I've also got my Atom (Issue 4) up and running but with weird video noise issues.
A messy display can be caused by a bad C4, you've already ordered a new set of capacitors so that's fine. I also had an Atom were the small choke (L1) was bad. That is easy to test by just soldering a short piece of wire parallel to it.
And please take notice that the Atom has screen noise by design when the cpu accesses the video memory without waiting for the video fly-back.
aerobaticant wrote:
Fri Jan 24, 2020 7:37 pm
Wish me luck!
Good luck!
Greetings from the south of the Netherlands

Re: Greetingsto all.

Posted: Wed Jan 29, 2020 6:25 am
by daveejhitchins
Welcome to the Forum, aerobaticant . . . Enjoy . . .

I've also got two Electrons, although one of them has a dead ULA.

Whatever you do PLEASE don't dump your dead Electron! - See here.

Dave H :D