Page 1 of 1

Just re-bought my 1st Acorn Atom

Posted: Mon Oct 02, 2017 8:19 pm
by fastirfred
Back in 1980 I bought my first computer kit, a Acorn Atom with all the ram I could get with the full interface and printer port. I used this for about 5 years and then got a Atari ST.
I gave my Acorn to my sister in South Africa where it may still exist. I have always regretted doing that.
Last week I won an ebay action for a Acorn in duibious condition (owner could not power it up) ...
On Friday I decided to test it ... I checked it out before powering up and as I have a bench psu decided to remove the regulators, make the links to power direct and turn on. At this point I did not have a monitor conected but confirmed it was working by typing garbage and then on return waiting for the 'error 94' beep :).

I was looking about the board with my scope and then noticed the current drain had shot up from 1.7amps to the 2 amp limit I had set on my psu. I tested the error 94 beep again and nothing ..:(
I then cobbled together a video cable to run from the com-vid out to my display... All I had on the screen on power up was a screen full of random characters. The break button did nothing ..
As all the chips are pluggable I decided to reeduce the ram to a minimum thinking that the change in current draw was possibly a chip issue. The ram chip ic 52 was hot to say the least. Once re-jigging the memory to emapt all but the ic 51-52 and ic42-43 I powered up and the current draw was now down to 1.3amps but the display what still rubbish.

I then decided to trace the reset(break) and could see tit going to all the main ic's but when investigating the 6502 although the reset was there I would have expected it to clock the R/W pin34 , nothing seen there on the scope. I then had a quick check of the pins around the cpu and found the there seemed to be a clock on pin 39 but pin 37 was flat.
I had a look on pin10 ic44 and the 1Mhz clock was there. Powering ogg I buzzed the link between ic44 pin 10 and the 6503 pin 37. This was o/c !. I pulled the 6502 and check pin 37. It was badly tarnished and a quick scrape with a fibre pensil sorted this. I retested the Atom with the cpu in and I had a display .... :) I pushed the remaining ram ic's in leaving the top 2 video chip out.(I've scoured around and bought a few from ebay). Waiting for delivery but I now have a working Acorn Atom. I found a 747.wav file and using my phone have been able to load the program and gety ti running.

So my 'new' atom has nearly it's full compliment of memory, a FP chip and a Disatom Rom .

On the strenth of this I decided to attempt to load the Amomulator onto my PC (linux mint 17) anf have failed .... Although I can run configure, make fails ..

Cheers for now Fraser

Re: Just re-bought my 1st Acorn Atom

Posted: Mon Oct 02, 2017 8:27 pm
by hoglet
fastirfred wrote: On the strenth of this I decided to attempt to load the Amomulator onto my PC (linux mint 17) anf have failed .... Although I can run configure, make fails ..
Welcome, and congratulations on fixing your Atom.

Atomulator (and B-Em) are a bit of a nightmare to build on recent Linux distributions, as they depend on Allegro version 4, which may not be available any more.

Have a go at the instructions here, and see what packages you are missing:
viewtopic.php?p=135158#p135158

Dave

Re: Just re-bought my 1st Acorn Atom

Posted: Mon Oct 02, 2017 8:35 pm
by daveejhitchins
Welcome to the Forum, Fraser . . . Enjoy . . .

And well done with your Atom =D>

Dave H :D

Re: Just re-bought my 1st Acorn Atom

Posted: Mon Oct 02, 2017 8:38 pm
by fastirfred
Wow,

I spent hours last night working through the issues with compiling and was nealry there all I needed was ....

make -f Makefile.linux

Thanks for your help .. I only signed up last night so could not post a request for help.

fraser

Re: Just re-bought my 1st Acorn Atom

Posted: Mon Oct 02, 2017 8:53 pm
by Multiwizard
Hi Fraser,

welcome to this great Forum... :D


Greetings from my little Dutch Acorn Attic, Wim... :-)

Re: Just re-bought my 1st Acorn Atom

Posted: Tue Oct 03, 2017 9:47 am
by oss003
Welcome Fraser,

you came to the right place ..... enjoy the forum ....
Nice to have another Atom working again.

Greetings
Kees

Re: Just re-bought my 1st Acorn Atom

Posted: Tue Oct 03, 2017 9:56 am
by flaxcottage
Welcome, Fraser. :D

Re: Just re-bought my 1st Acorn Atom

Posted: Tue Oct 03, 2017 10:31 am
by DutchAcorn
Welcome Frasier, it sounds like you already had a lot of fun with the Atom. Enjoy Stardot! :D

Re: Just re-bought my 1st Acorn Atom

Posted: Tue Oct 03, 2017 1:16 pm
by davidb
Welcome! :D

Re: Just re-bought my 1st Acorn Atom

Posted: Wed Oct 04, 2017 6:36 am
by danielj
Hello there! :)

Re: Just re-bought my 1st Acorn Atom

Posted: Wed Oct 04, 2017 4:55 pm
by CMcDougall
welcome Fraser :)

nice one on the Atom =D>