Search found 160 matches

by aotta
Sun Nov 11, 2018 10:53 pm
Forum: hardware
Topic: SpectROM - Speccy emulator for the Pi co-pro
Replies: 182
Views: 10890

Re: SpectROM - Speccy emulator for the Pi co-pro

i tried to launch zxspec, following instruction displayed with !boot on ssd spectrom, but i get "bad command" error with MOS 3.2 in my Master (@RobC: i take off for the moment one of my 2 videonula from other BBC... but i hope to get my 3rd vnula soon! ;) ). *zxinit let screen a bit darker, and *zxs...
by aotta
Sun Nov 11, 2018 11:52 am
Forum: hardware
Topic: Retro Hardware ARA III - Low Cost Writable ROM Cartridge - For the Electron and Master
Replies: 36
Views: 1601

Re: Retro Hardware ARA III - Low Cost Writable ROM Cartridge - For the Electron and Master

Reallly an interesting project Dave!
i am interested in one or two pcbs too... are there some left?
You should put a countdown counter for them! :)
by aotta
Fri Nov 09, 2018 8:48 am
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 782

Re: Help for a WE RAM / ROM board not working

Thanks Kazzle, your hints are very helpful! I will use the weekend for resocketing and getting pics of board when "nude". A little OT, about instruments, I bought from aliexpress the scope (LA1010 usb) for 25£ shipped, after some years of a Diy kit that worked in a very random way. And, from aliexpr...
by aotta
Fri Nov 09, 2018 6:45 am
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 782

Re: Help for a WE RAM / ROM board not working

Kazzle, now I realized that there was a misunderstanding: S21E goes to IC18 (the sl138), and I referred test and probing to it, while you was talking about ic16! Really sorry for it, I will have to sleep a bit more in the night instead of playing with old computers.. 😁 Anyway I'll follow your guidel...
by aotta
Thu Nov 08, 2018 11:56 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 782

Re: Help for a WE RAM / ROM board not working

in my case it seems i have two inputs... it's not the wiring the fault Ah. Ok. Is it possible that S21W is actually connected to more than one IC on the ROM / RAM board, or to more than one pin on IC1? That's what i thought too and... yes! s23w is connected to IC19 pin 8 too (74ls20)... an output! ...
by aotta
Thu Nov 08, 2018 10:37 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 782

Re: Help for a WE RAM / ROM board not working

Thank you Kenlowe for the info, but in my case it seems i have two inputs... it's not the wiring the fault, but i'd like to understand the board to perform further test.
by aotta
Thu Nov 08, 2018 10:14 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 782

Re: Help for a WE RAM / ROM board not working

But.. S21 West is connected to Pin 1 of IC1 (74ls00), that is an input to the first nand gate of ICs... and pin 3 in fact is not flat and waves... So, is W the input and E the output, or viceversa? i am confused... That does sound like it's the wrong way round! On the beeb motherboard S21 SE is nor...
by aotta
Thu Nov 08, 2018 9:28 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 782

Re: Help for a WE RAM / ROM board not working

Does the board need it's own 5v supply? Where does it pick that up from? it keep power from vcc2 psu spades and return it to board with its wires... But.. S21 West is connected to Pin 1 of IC1 (74ls00), that is an input to the first nand gate of ICs... and pin 3 in fact is not flat and waves... So,...
by aotta
Thu Nov 08, 2018 8:58 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 782

Re: Help for a WE RAM / ROM board not working

So the Beeb is sending plenty of (active low) S21 requests to the board, but the board isn't sending any back. That's in keeping with the behaviour you've described so far. (BTW, is S21E connected to IC16 pin 5 or pin 6? Your last two posts mention both pins.) Now that you've got a scope to hand, i...
by aotta
Thu Nov 08, 2018 7:09 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 782

Re: Help for a WE RAM / ROM board not working

Anyway, i get this wave at boot for S21 pins from expansion board:
S21WE.png
West go high and stay there...
by aotta
Thu Nov 08, 2018 6:42 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 782

Re: Help for a WE RAM / ROM board not working

Briliant analysis!
i confirm West S21 is connected to IC1 pin 1, and Est S21 to pin 5 IC18 (active low inputs? i expected an output...)
i'll made some test... if only i'll find the probe for my usb scope... it's an hour i am looking for them! :oops:
by aotta
Thu Nov 08, 2018 2:49 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 782

Re: Help for a WE RAM / ROM board not working

Great work Mark, even better than schematics! I will start this evening from suspect ICs, testing continuity and looking for correct response.. Some works to do!
by aotta
Thu Nov 08, 2018 2:02 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 782

Re: Help for a WE RAM / ROM board not working

@Paul: a test without ram was one of first things I tried.. No difference
@kazzle & Mark: thanks for all info! I had a little idea of selection logic, made myself while doing the "diy sw ram for under a fiver" in other BBC... Now I have more starting point for testing.
by aotta
Thu Nov 08, 2018 12:08 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 782

Re: Help for a WE RAM / ROM board not working

Thank you Kazzle, you explained very well the rom selection logic, and confirmed most of the ideas I made myself. I have already checked E and W expansion board for continuity, and they are ok from connectors to the two ICs on the Watford card. So, I am afraid of one or more 74xx failure, but they a...
by aotta
Thu Nov 08, 2018 10:32 am
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 782

Re: Help for a WE RAM / ROM board not working

Thank you Mark, control signal and control circuit is the direction I intend investigate, since the only case I get basic rom working is when fitted in mb slot and link S21 closed with classic bridge (I.e. not connected to expansion board via dedicated wires). All other combinations port to "languag...
by aotta
Thu Nov 08, 2018 9:16 am
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 782

Re: Help for a WE RAM / ROM board not working

Thank you, but i am sure it's not a metter of slots or eprom, they work fine in mb slots and in mb other micros, and i tried a lot of combination, included no rom at all on expansion board, getting always the "language? " prompt... 😔
by aotta
Thu Nov 08, 2018 6:22 am
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 782

Re: Help for a WE RAM / ROM board not working

Just got the same board in a BBC last weekend. The user guide is here: http://chrisacorns.computinghistory.org.uk/docs/Watford/WE_RAMROMBoard.pdf Thank you Paul, but it's the manual I quoted in my first post, and it only relate "language?" Error to S21 link. I had the 2 fixed voltage I reported in ...
by aotta
Wed Nov 07, 2018 10:45 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 782

Re: Help for a WE RAM / ROM board not working

found : https://stardot.org.uk/forums/viewtopic.php?f=3&t=8755&p=96318&hilit=watford+rom+ram+disc#p96318 your board should be like this, ignore the extra ram top right : Really a monster your WE! why didn't you fit the battery? you already put the read only switch i se... if i'll get mine working, ...
by aotta
Wed Nov 07, 2018 10:38 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 782

Re: Help for a WE RAM / ROM board not working

Thanks for the hints CMcDougall, but it's not the slot the problem.. i made several tests, but even without any roms in the boards i get only the "language?" error...
by aotta
Wed Nov 07, 2018 10:19 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 782

Re: Help for a WE RAM / ROM board not working

That's the WE ram/rom 128k board:
WERAMROM_front.jpg
by aotta
Wed Nov 07, 2018 9:18 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 782

Help for a WE RAM / ROM board not working

I bought in the bay a second BBC Micro, reasonable price, with an interesting big black suitcase with Micro siluette for carrying it (yes, a portable beeb diy!) :lol: I power on it and.... continuos beep! Ok, let's look inside. Open the case and... a varta 3.6 battery rolls away on the table, and a ...
by aotta
Fri Oct 19, 2018 10:55 am
Forum: for sale / freebies
Topic: Aries shadow RAM boards
Replies: 6
Views: 598

Re: Aries shadow RAM boards

Hi Philb, i am interested in one of the B32's, is there one still available?
by aotta
Fri Oct 12, 2018 4:29 pm
Forum: hardware
Topic: New A3000 4MB memory
Replies: 71
Views: 3673

Re: New A3000 4MB memory

Good news! My complimenta to you and ians!
by aotta
Tue Sep 18, 2018 5:18 pm
Forum: hardware
Topic: IDE interfaces - hardware details
Replies: 112
Views: 5605

Re: IDE interfaces - hardware details

i used simple "male pin strip" bought for pennies in the bay, cutted and soldered in 2 rows... if you have to cut.. what's about doing same thing with female ones?
by aotta
Wed Sep 12, 2018 7:54 pm
Forum: hardware
Topic: New A3000 4MB memory
Replies: 71
Views: 3673

Re: New A3000 4MB memory

Great works! And your desk is in great order compared to my kitchen! (My Amiga 600 still doesn't boot.. I must move soldering station elsewhere ...) :lol:
by aotta
Fri Sep 07, 2018 5:10 pm
Forum: wanted
Topic: Looking for A5000 motherboard
Replies: 0
Views: 415

Looking for A5000 motherboard

After hours spent in trying to repair the A5000 i bought "not working" in the bay, i must admit it's death.

Anyone has in a A5000's motherboard to sell at a reasonable price? [-o<
by aotta
Thu Sep 06, 2018 2:17 pm
Forum: hardware
Topic: A5000 but no display..."Out of Range"
Replies: 13
Views: 629

Re: A5000 but no display..."Out of Range"

And a useful proof about A5000 is working may be if it "beep" when booting, and if keyboard leds works.
And, of course, opening the A5000 and looking around battery area. As robc said, I am afraid the A5000 is damaged, and it is not a video question... I hope for you I am wrong
by aotta
Thu Sep 06, 2018 1:59 pm
Forum: hardware
Topic: Please help with another blooming "I just got a BEEB from Ebay" thread :-)
Replies: 44
Views: 1220

Re: Please help with another blooming "I just got a BEEB from Ebay" thread :-)

Thanks, sorry I'm confused what do I use the db9 serial cable for, the mouse? I thought I plugged the mouse into the DIN socket at the rear of the keyboard? No, you are right, the standard mouse port is a mini Din-9. I was confused by your writing about the DB9, and i thought you was planning a DB9...
by aotta
Thu Sep 06, 2018 1:39 pm
Forum: hardware
Topic: Please help with another blooming "I just got a BEEB from Ebay" thread :-)
Replies: 44
Views: 1220

Re: Please help with another blooming "I just got a BEEB from Ebay" thread :-)

I usually use db9 serial cable, cheap and with less wires than a scart.
Give a tray to your floppy and ide ports if working, you can check them from command line, without mouse.
If you had damage to keyboard tracks, more probably you lost some connection on that ports, that are nearest to battery
by aotta
Tue Sep 04, 2018 10:27 pm
Forum: hardware
Topic: New A3000 4MB memory
Replies: 71
Views: 3673

Re: New A3000 4MB memory

So, in a couple of months they will arrive! :lol: