Search found 16 matches

by TimbukToo
Mon Jun 15, 2020 10:09 am
Forum: 8-bit acorn hardware
Topic: Video Issue - Model B
Replies: 5
Views: 789

Re: Video Issue - Model B

Hello I know this is an old thread but I've just got to thank you KenLowe.
I've had an issue with no output on the RGB to my scart-HDMI box and changing S31 from East to West and presto FIXED :D
Cheers
by TimbukToo
Thu Feb 20, 2020 10:14 pm
Forum: 8-bit acorn hardware
Topic: Re: BBC model b serious sound issue
Replies: 5
Views: 333

Re: BBC model b serious sound issue

BeebMaster wrote:
Thu Feb 20, 2020 5:02 pm
I'd certainly suspect IC32 (74LS259) as I had a BBC Model B which did almost exactly the same thing till it was replaced.
Thanks mate, I've ordered some of those off ebay and will update :)
by TimbukToo
Thu Feb 20, 2020 3:05 pm
Forum: 8-bit acorn hardware
Topic: Re: BBC model b serious sound issue
Replies: 5
Views: 333

Re: BBC model b serious sound issue

If the computer is freezing then that indicates something on the "digital side" of the sound generator First port of call is the system VIA Then working your way from the CPU towards the speaker IC3 System VIA IC32 74LS259 IC99 (Speech processor - if installed, extract it to test) 76489 IC17 LM324 ...
by TimbukToo
Thu Feb 20, 2020 2:40 pm
Forum: 8-bit acorn hardware
Topic: Re: BBC model b serious sound issue
Replies: 5
Views: 333

Re: BBC model b serious sound issue

Hello again. Thanks to Dave the VIA problem is fixed :D Now the bad news :( Sound on switch on is monotonal 2 sounds (the second is like a horn) not a beep and a chord like my other working machine. Now I can load games, games with simple sound effects and beeps run fine, whereas games with complex ...
by TimbukToo
Thu Feb 20, 2020 6:10 am
Forum: 8-bit acorn hardware
Topic: user VIA ic69 faulty?
Replies: 14
Views: 568

Re: user VIA ic69 faulty?

Thanks everyone for your help.
Dave H sent me an ic69 and everything looks fine so far (Thanks Dave)
Another issue i've discovered now I can load games is there seems to be only one sound channel. Games utilising more than 1 channel crash or not run at all. :(
Again thanks Ian
by TimbukToo
Wed Feb 12, 2020 6:25 am
Forum: introduce yourself
Topic: Hello from QLD Australia
Replies: 17
Views: 995

Re: Hello from QLD Australia

Oh no ... you didn't buy that Model B from Melbourne that was on eBay just before Christmas? If it's the one I'm thinking of, I reckon I may have put a bid on it. I knew it was a fixer-upper, but it sounds like it might need more fixing that first thought ...! (a bit more than just a PSU reecapping...
by TimbukToo
Wed Feb 12, 2020 2:50 am
Forum: introduce yourself
Topic: Hi from Adelaide, Australia
Replies: 9
Views: 541

Re: Hi from Adelaide, Australia

G'day mate, welcome and thanks for the mention :wink: Yeah I bought that one and the one before it. The first one was cosmetically great but sick on the inside. The second one was the opposite. So from the two I've got a descent micro. The first one will hopefully running nice when the parts arrive ...
by TimbukToo
Wed Feb 05, 2020 6:35 am
Forum: wanted
Topic: Wanted: User VIA IC69 and couple of other chips
Replies: 1
Views: 381

Wanted: User VIA IC69 and couple of other chips

Hello. Bought a beeb recently with missing IC7 IC73 not critical but I want them for completeness. More importantly IC69 is buggered. I have a couple on order on slow boat from China. Don't know if they will ever come or if they are any good so if there is any kind person on here who can help me out...
by TimbukToo
Sun Feb 02, 2020 10:59 am
Forum: 8-bit acorn hardware
Topic: user VIA ic69 faulty?
Replies: 14
Views: 568

Re: user VIA ic69 faulty?

Ahh, sorry, did not notice where you’re from :oops: So yeah, China may be easier than Dave H :D sending out from the U.K.... Mark :lol: no worries, I'll risk the Chinese quality, sorry I did see that link to Dave's page but had forgotten after all the fun and games with chip swapping. Hopefully thi...
by TimbukToo
Sun Feb 02, 2020 10:36 am
Forum: 8-bit acorn hardware
Topic: user VIA ic69 faulty?
Replies: 14
Views: 568

Re: user VIA ic69 faulty?

I agree, don’t bother with an IC extractor. This subject often comes up ... and do read this thread :wink: Mark ok thanks Mark and Daniel, Did as you suggested and something interesting occured. Swapped over chips and got continuous BEEP as others have had. So swapped back and the beeb refused to b...
by TimbukToo
Sun Feb 02, 2020 9:52 am
Forum: introduce yourself
Topic: Hello from QLD Australia
Replies: 17
Views: 995

Re: Hello from QLD Australia

tricky wrote:
Sun Feb 02, 2020 8:37 am
Welcome, I wonder if your beeb came from one of our Melbourne members.
Thanks mate.
Don't think so but maybe. If so I'd like to have a chat :wink:
by TimbukToo
Sun Feb 02, 2020 9:49 am
Forum: introduce yourself
Topic: Hello from QLD Australia
Replies: 17
Views: 995

Re: Hello from QLD Australia

daveejhitchins wrote:
Sun Feb 02, 2020 8:15 am
Welcome to the forum, Ian . . . Enjoy . . .
TimbukToo wrote:
Sat Feb 01, 2020 11:25 pm
Got an Electron for Xmas 84, and it still works to this day
=D>

Dave H :D
Yeah don't make 'em like that anymore. And thanks for the welcome.
by TimbukToo
Sun Feb 02, 2020 9:46 am
Forum: 8-bit acorn hardware
Topic: user VIA ic69 faulty?
Replies: 14
Views: 568

Re: user VIA ic69 faulty?

my results are PRINT ?&FE60 returns 107 PRINT ?&FE61 returns 0 PRINT ?&FE62 returns 159 PRINT ?&FE63 returns 255 ?&FE62 = 255 ?&FE63 = 255 PRINT ?&FE60 returns 11 PRINT ?&FE61 returns 0 any thoughts? Was this with nothing connected to the User Port and nothing connected to the Printer Port, and aft...
by TimbukToo
Sat Feb 01, 2020 11:47 pm
Forum: 8-bit acorn hardware
Topic: user VIA ic69 faulty?
Replies: 14
Views: 568

Re: user VIA ic69 faulty?

1024MAK wrote:
Sat Feb 01, 2020 11:02 pm
See here for results with nothing connected to the user port.

Mark
Thanks Mark.
my results are
PRINT ?&FE60 returns 107
PRINT ?&FE61 returns 0
PRINT ?&FE62 returns 159
PRINT ?&FE63 returns 255
?&FE62 = 255
?&FE63 = 255
PRINT ?&FE60 returns 11
PRINT ?&FE61 returns 0
any thoughts?
by TimbukToo
Sat Feb 01, 2020 11:25 pm
Forum: introduce yourself
Topic: Hello from QLD Australia
Replies: 17
Views: 995

Hello from QLD Australia

Hello all, Used BBC's in high school and enjoyed writing basic programming. Got an Electron for Xmas 84, and it still works to this day :D with drbombcrater's ElkSD64 (thanks Gary) it lives again. I thought I'd "upgrade" to a beeb and bought one from Melbourne. It looked good in the pictures (famous...
by TimbukToo
Sat Feb 01, 2020 10:41 pm
Forum: 8-bit acorn hardware
Topic: user VIA ic69 faulty?
Replies: 14
Views: 568

user VIA ic69 faulty?

Hello first time post here, Just recently bought a BBC model b issue 7 off Ebay. Everything looked fine in the pics showed various games running including snapper very clean machine, anyway. Popped the lid off only to find a number of chips missing; ic7 and ic73. Not critical but no tape or A/D fine...

Go to advanced search