Search found 116 matches

by aotta
Wed Nov 28, 2018 6:26 am
Forum: hardware
Topic: IDE interfaces - hardware details
Replies: 83
Views: 3455

Re: IDE interfaces - hardware details

I'm just happy that you got them both working. How many PCB's did you get made, are you going to populate them and sell any? I've a A3000, a A4000 and a A5000, so i made two 8 bit and one 16 bit boards. I had to order 10 PCBs for each version, so I had some left and maybe l'll populate one or two m...
by aotta
Tue Nov 27, 2018 10:58 pm
Forum: hardware
Topic: IDE interfaces - hardware details
Replies: 83
Views: 3455

Re: IDE interfaces - hardware details

The front HD LED is wired into the internal IDE port, so it would be difficult to make it flash for the podule access. You could wire up the front power LED to the podule, then depending on the which way round you connect the wires, the LED will be on or off when the drive is accessed. So you could...
by aotta
Tue Nov 27, 2018 9:26 pm
Forum: hardware
Topic: IDE interfaces - hardware details
Replies: 83
Views: 3455

Re: IDE interfaces - hardware details

Found the bug! and was wery small... a drill on the pcb in the D2 line from ROM and GAL was scrapy.. and line interrupted! a wire solved and podule start! now trying to use hform on CF card without formatting my IDE Discs... :lol: Run hform from floppy, and disconnect the IDE connected to the on-bo...
by aotta
Tue Nov 27, 2018 6:29 pm
Forum: hardware
Topic: IDE interfaces - hardware details
Replies: 83
Views: 3455

Re: IDE interfaces - hardware details

it seems the 3rd bit (4) is always set.. :wink: Yep, time to check your soldering. Yes, great idea give a look in memory! Many thanks again! Found the bug! and was wery small... a drill on the pcb in the D2 line from ROM and GAL was scrapy.. and line interrupted! a wire solved and podule start! now...
by aotta
Tue Nov 27, 2018 12:32 am
Forum: hardware
Topic: IDE interfaces - hardware details
Replies: 83
Views: 3455

Re: IDE interfaces - hardware details

IanS wrote:
Tue Nov 27, 2018 12:28 am
aotta wrote:
Tue Nov 27, 2018 12:14 am
it seems the 3rd bit (4) is always set.. :wink:
Yep, time to check your soldering.
Yes, great idea give a look in memory! Many thanks again!
by aotta
Tue Nov 27, 2018 12:14 am
Forum: hardware
Topic: IDE interfaces - hardware details
Replies: 83
Views: 3455

Re: IDE interfaces - hardware details

mmhh.. a lot of difference, in fact:
debug.jpg
it seems the 3rd bit (4) is always set.. :wink:
by aotta
Mon Nov 26, 2018 10:45 pm
Forum: hardware
Topic: IDE interfaces - hardware details
Replies: 83
Views: 3455

Re: IDE interfaces - hardware details

IanS wrote:
Mon Nov 26, 2018 10:40 pm

Try this for the GAL.
IDE_Podule.zip
Thank you, but no difference... always same exception.

I will recheck all solders tomorrow and made further test.. :(
by aotta
Mon Nov 26, 2018 10:33 pm
Forum: hardware
Topic: IDE interfaces - hardware details
Replies: 83
Views: 3455

Re: IDE interfaces - hardware details

too beauty to be real... finished assembling 16bit board, installed on the A5000 and: - with ide (cf or real hd) connected, hangs on purple screen; - without ide connected, it boot but at *podules command i get: "internal error: address exception at &0382601c", with all four combination of jp1 & jp...
by aotta
Mon Nov 26, 2018 9:52 pm
Forum: hardware
Topic: IDE interfaces - hardware details
Replies: 83
Views: 3455

Re: IDE interfaces - hardware details

too beauty to be real... finished assembling 16bit board, installed on the A5000 and: - with ide (cf or real hd) connected, hangs on purple screen; - without ide connected, it boot but at *podules command i get: "internal error: address exception at &0382601c", with all four combination of jp1 & jp2...
by aotta
Sun Nov 25, 2018 11:16 pm
Forum: hardware
Topic: IDE interfaces - hardware details
Replies: 83
Views: 3455

Re: IDE interfaces - hardware details

Thank you IanS for all info! I need it for my a5000 (finally I made a working ones) and I will use a CF card, so I"ll solder a simple wire or a 0R resistor, and left jumper (and led) as already done.
Thank you again!
by aotta
Sun Nov 25, 2018 10:43 pm
Forum: hardware
Topic: IDE interfaces - hardware details
Replies: 83
Views: 3455

Re: IDE interfaces - hardware details

i am working on 16bit podule version, i am missing only soldering resistors but i need some help for their values (for r8 to r31 ones) and i am not sure about j1 and jp3 role..
Ide16.jpg
may be give me a little help IanS?
by aotta
Thu Nov 15, 2018 6:34 am
Forum: hardware
Topic: Model B PSU fuse go bang.
Replies: 17
Views: 531

Re: Model B PSU fuse go bang.

I exploded 2 fuse while recapping micro psu in the last weeks, and in both cases it was because residual fluxing paste take a short circuit between 2 tracks (the gap between tracks near the 2 paper caps are very thin, and ac 220v is not like low voltage dc). I clean pcb with IPA, mounted new fuse an...
by aotta
Thu Nov 15, 2018 6:14 am
Forum: hardware
Topic: SpectROM - Speccy emulator for the Pi co-pro
Replies: 181
Views: 9254

Re: SpectROM - Speccy emulator for the Pi co-pro

Best wishes to your mother, and happy you are getting something new about vnula from your magic hat!
by aotta
Wed Nov 14, 2018 4:10 pm
Forum: hardware
Topic: SpectROM - Speccy emulator for the Pi co-pro
Replies: 181
Views: 9254

Re: SpectROM - Speccy emulator for the Pi co-pro

Rob, can you confirm the emu you are working on doesn't need update to vnula's board, since cpc colors are the same vnula already supports?
We are all waiting for your release... :D
by aotta
Tue Nov 13, 2018 10:33 pm
Forum: hardware
Topic: SpectROM - Speccy emulator for the Pi co-pro
Replies: 181
Views: 9254

Re: SpectROM - Speccy emulator for the Pi co-pro

VectorEyes wrote:
Tue Nov 13, 2018 10:30 pm
My God... If ever there was an excuse to get a Pi CoPro, I think this was it!
..and to get a Videonula! =D>
by aotta
Mon Nov 12, 2018 10:22 am
Forum: hardware
Topic: SpectROM - Speccy emulator for the Pi co-pro
Replies: 181
Views: 9254

Re: SpectROM - Speccy emulator for the Pi co-pro

Good news! It's incredible what you can squeeze out from a bbc & vnula! Good luck for your debugging!
by aotta
Sun Nov 11, 2018 10:53 pm
Forum: hardware
Topic: SpectROM - Speccy emulator for the Pi co-pro
Replies: 181
Views: 9254

Re: SpectROM - Speccy emulator for the Pi co-pro

i tried to launch zxspec, following instruction displayed with !boot on ssd spectrom, but i get "bad command" error with MOS 3.2 in my Master (@RobC: i take off for the moment one of my 2 videonula from other BBC... but i hope to get my 3rd vnula soon! ;) ). *zxinit let screen a bit darker, and *zxs...
by aotta
Sun Nov 11, 2018 11:52 am
Forum: hardware
Topic: Retro Hardware ARA III - Low Cost Writable ROM Cartridge - For the Electron and Master
Replies: 34
Views: 1150

Re: Retro Hardware ARA III - Low Cost Writable ROM Cartridge - For the Electron and Master

Reallly an interesting project Dave!
i am interested in one or two pcbs too... are there some left?
You should put a countdown counter for them! :)
by aotta
Fri Nov 09, 2018 8:48 am
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 580

Re: Help for a WE RAM / ROM board not working

Thanks Kazzle, your hints are very helpful! I will use the weekend for resocketing and getting pics of board when "nude". A little OT, about instruments, I bought from aliexpress the scope (LA1010 usb) for 25£ shipped, after some years of a Diy kit that worked in a very random way. And, from aliexpr...
by aotta
Fri Nov 09, 2018 6:45 am
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 580

Re: Help for a WE RAM / ROM board not working

Kazzle, now I realized that there was a misunderstanding: S21E goes to IC18 (the sl138), and I referred test and probing to it, while you was talking about ic16! Really sorry for it, I will have to sleep a bit more in the night instead of playing with old computers.. 😁 Anyway I'll follow your guidel...
by aotta
Thu Nov 08, 2018 11:56 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 580

Re: Help for a WE RAM / ROM board not working

in my case it seems i have two inputs... it's not the wiring the fault Ah. Ok. Is it possible that S21W is actually connected to more than one IC on the ROM / RAM board, or to more than one pin on IC1? That's what i thought too and... yes! s23w is connected to IC19 pin 8 too (74ls20)... an output! ...
by aotta
Thu Nov 08, 2018 10:37 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 580

Re: Help for a WE RAM / ROM board not working

Thank you Kenlowe for the info, but in my case it seems i have two inputs... it's not the wiring the fault, but i'd like to understand the board to perform further test.
by aotta
Thu Nov 08, 2018 10:14 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 580

Re: Help for a WE RAM / ROM board not working

But.. S21 West is connected to Pin 1 of IC1 (74ls00), that is an input to the first nand gate of ICs... and pin 3 in fact is not flat and waves... So, is W the input and E the output, or viceversa? i am confused... That does sound like it's the wrong way round! On the beeb motherboard S21 SE is nor...
by aotta
Thu Nov 08, 2018 9:28 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 580

Re: Help for a WE RAM / ROM board not working

Does the board need it's own 5v supply? Where does it pick that up from? it keep power from vcc2 psu spades and return it to board with its wires... But.. S21 West is connected to Pin 1 of IC1 (74ls00), that is an input to the first nand gate of ICs... and pin 3 in fact is not flat and waves... So,...
by aotta
Thu Nov 08, 2018 8:58 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 580

Re: Help for a WE RAM / ROM board not working

So the Beeb is sending plenty of (active low) S21 requests to the board, but the board isn't sending any back. That's in keeping with the behaviour you've described so far. (BTW, is S21E connected to IC16 pin 5 or pin 6? Your last two posts mention both pins.) Now that you've got a scope to hand, i...
by aotta
Thu Nov 08, 2018 7:09 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 580

Re: Help for a WE RAM / ROM board not working

Anyway, i get this wave at boot for S21 pins from expansion board:
S21WE.png
West go high and stay there...
by aotta
Thu Nov 08, 2018 6:42 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 580

Re: Help for a WE RAM / ROM board not working

Briliant analysis!
i confirm West S21 is connected to IC1 pin 1, and Est S21 to pin 5 IC18 (active low inputs? i expected an output...)
i'll made some test... if only i'll find the probe for my usb scope... it's an hour i am looking for them! :oops:
by aotta
Thu Nov 08, 2018 2:49 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 580

Re: Help for a WE RAM / ROM board not working

Great work Mark, even better than schematics! I will start this evening from suspect ICs, testing continuity and looking for correct response.. Some works to do!
by aotta
Thu Nov 08, 2018 2:02 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 580

Re: Help for a WE RAM / ROM board not working

@Paul: a test without ram was one of first things I tried.. No difference
@kazzle & Mark: thanks for all info! I had a little idea of selection logic, made myself while doing the "diy sw ram for under a fiver" in other BBC... Now I have more starting point for testing.
by aotta
Thu Nov 08, 2018 12:08 pm
Forum: hardware
Topic: Help for a WE RAM / ROM board not working
Replies: 45
Views: 580

Re: Help for a WE RAM / ROM board not working

Thank you Kazzle, you explained very well the rom selection logic, and confirmed most of the ideas I made myself. I have already checked E and W expansion board for continuity, and they are ok from connectors to the two ICs on the Watford card. So, I am afraid of one or more 74xx failure, but they a...