BeebEm3s Hard Drive Image and ADFS Explorer

ask about 32-bit emulators like ArcEm, Red Squirrel, Arculator or RPCEmu here
User avatar
daveejhitchins
Posts: 3690
Joined: Wed Jun 13, 2012 5:23 pm
Location: Newton Aycliffe, County Durham

BeebEm3s Hard Drive Image and ADFS Explorer

Postby daveejhitchins » Fri Mar 18, 2016 10:35 pm

I'm trying to load some files onto BeemEm3s hard drive: scsi0.dat using ADFS Explorer. I can load the image into ADFS Explorer and create the Directories I need and fill them . . . However, I don't seem to be able to save the updated image file scsi0.dat.

Firstly, should I be able to do this and secondly, if I can (?) where am I going wrong?

Thanks - Dave H :D
Parts: UM6502CE, GAL22V10D, GAL16V8D, AS6C62256A, TC514400AZ, WD1772, R6522, TMS27C512, AT28C256
Products: ARA II, ABR, ATI, AP6, MGC, AP5 . . .
For a price list, contact me at: Retro Hardware AT dave ej hitchins DOT plus DOT com

stevei2791
Posts: 22
Joined: Sat Aug 29, 2015 12:21 pm
Location: Irchester

Re: BeebEm3s Hard Drive Image and ADFS Explorer

Postby stevei2791 » Fri Mar 18, 2016 10:58 pm

I believe that the save function requires you to purchase a license from Jon, its disabled in the free version.

User avatar
daveejhitchins
Posts: 3690
Joined: Wed Jun 13, 2012 5:23 pm
Location: Newton Aycliffe, County Durham

Re: BeebEm3s Hard Drive Image and ADFS Explorer

Postby daveejhitchins » Sat Mar 19, 2016 8:33 am

stevei2791 wrote:I believe that the save function requires you to purchase a license from Jon, its disabled in the free version.
I have the paid-for-version for both DFS Explorer and ADFS Explorer . . . I can save normal sized disc images OK . . . So I'm stumped :?

Dave H :D
Parts: UM6502CE, GAL22V10D, GAL16V8D, AS6C62256A, TC514400AZ, WD1772, R6522, TMS27C512, AT28C256
Products: ARA II, ABR, ATI, AP6, MGC, AP5 . . .
For a price list, contact me at: Retro Hardware AT dave ej hitchins DOT plus DOT com

User avatar
daveejhitchins
Posts: 3690
Joined: Wed Jun 13, 2012 5:23 pm
Location: Newton Aycliffe, County Durham

Re: BeebEm3s Hard Drive Image and ADFS Explorer

Postby daveejhitchins » Sat Mar 19, 2016 9:12 am

A little more information:

I created a new Hard Drive image (16MB), within ADFS Explorer, and transferred all the files from the BeebEm3 Hard Drive (scsi0.dat) Saved as scsi0.dat, however, BebEm3 reports a Broken Directory - This may have something to do with the associated file: scsi0.dsc - Darn, better read the BeebEm3 instructions :oops:

Edit: Hmmm! Nothing there :(

Dave H :D
Parts: UM6502CE, GAL22V10D, GAL16V8D, AS6C62256A, TC514400AZ, WD1772, R6522, TMS27C512, AT28C256
Products: ARA II, ABR, ATI, AP6, MGC, AP5 . . .
For a price list, contact me at: Retro Hardware AT dave ej hitchins DOT plus DOT com

User avatar
daveejhitchins
Posts: 3690
Joined: Wed Jun 13, 2012 5:23 pm
Location: Newton Aycliffe, County Durham

Re: BeebEm3s Hard Drive Image and ADFS Explorer

Postby daveejhitchins » Mon Mar 21, 2016 8:22 am

I've moved forward with this issue . . .

I installed and registered the Windows versions of ADFS Explorer (and DFS Explorer, while I was there :D ) and the problem doesn't exist. On contacting Jon Welch he offered to look at the problem and provide a fix. That's refreshing, what a nice guy =D>

Dave H :D
Parts: UM6502CE, GAL22V10D, GAL16V8D, AS6C62256A, TC514400AZ, WD1772, R6522, TMS27C512, AT28C256
Products: ARA II, ABR, ATI, AP6, MGC, AP5 . . .
For a price list, contact me at: Retro Hardware AT dave ej hitchins DOT plus DOT com

User avatar
daveejhitchins
Posts: 3690
Joined: Wed Jun 13, 2012 5:23 pm
Location: Newton Aycliffe, County Durham

Re: BeebEm3s Hard Drive Image and ADFS Explorer

Postby daveejhitchins » Mon Mar 21, 2016 6:26 pm

It's now sorted :D

One of the first things I did was to check for an update of ADFS Explorer. I looked on the site and found that the version to download was the same version I was running (2.0). So didn't look any further. Jon, however, said there was an updated version (2.1) that actually fixed the problem I was seeing. He also attached the updated version - which did fix this issue.

When I went back to the Mac ADFS Explorer page and scrolled down - the version history showed version 2.1 - but the download link still showed version 2.0 with a 2007 date. Not sure if the link points to 2.1 though!

Anyway all sorted :D

Dave H :D
Parts: UM6502CE, GAL22V10D, GAL16V8D, AS6C62256A, TC514400AZ, WD1772, R6522, TMS27C512, AT28C256
Products: ARA II, ABR, ATI, AP6, MGC, AP5 . . .
For a price list, contact me at: Retro Hardware AT dave ej hitchins DOT plus DOT com


Return to “emulators”

Who is online

Users browsing this forum: No registered users and 2 guests