Faulty A3020

Arc/RPCs, peripherals, RISCOS operating system & ARM kit eg GP2x, BeagleBoard
Posts: 503
Joined: Fri Aug 28, 2015 8:34 pm

Faulty A3020

Postby SteveF » Sun Sep 03, 2017 2:03 pm

Hi all,

I'm trying to resurrect an A3020 which has been stuck in the garage for about 15 years and I'd appreciate any advice you can offer. I fear this is pushing the envelope of my hardware abilities but let's see how it goes...

I tested this before it was put into storage and it did work then. It's a standard A3020 with 2MB RAM, RISC OS 3.11 and a single floppy drive, nothing else.

A couple of months ago I dug it out, cut off the corroded CMOS battery and washed the PCB with white vinegar and deionised water, giving it a gentle scrub with an old toothbrush at the same time. There was a fair amount of bright green gunk on the rear connectors and a certain amount of what looked like rust, although the circuit board itself doesn't look too badly damaged to my inexperienced eye.

After letting it dry off I powered it up without a monitor attached and I did succeed in getting it to a point (probably with a certain amount of holding R and/or DELETE down during power-on) where I could press F12 to get an (invisible) prompt, toggle Caps Lock on and off and press Ctrl-G to make it beep.

Flushed with success I attached an old AKF18 monitor and a mouse and naturally the system then decided it was not going to boot to the desktop any more. Now when I power it on I get a rolling solid red display on the AKF18 and a 32-bit code flashed out on the floppy drive LED and that's that. The flash sequence is SSSS SSSS SSSS SSLS SSSS SSSL SLSS SSSL which I make out to be fault code &00020141. Looking at http://www.retro-kit.co.uk/user/custom/ ... ote225.pdf I interpret that as:
  • Self-test due to power-on
  • PC-style IO world detected
  • Ram control line failure
with the &100 bit unexplained.

I have soldered on a 2xAA battery holder and installed 2xNiMH AA rechargeables (pre-charged) in it in the hope of that helping, but it hasn't made any difference. (At least it hasn't made things any worse either...)

Examining the circuit board a bit more closely in the hope of spotting obvious track damage (not that I'm sure I know exactly what it looks like), most of it doesn't seem that bad to me, although the underside of the mouse socket does look quite a mess. I've attached some photos; I have some others and can try to take some more if anyone wants a closer look at any area in particular, but as they're quite big I didn't want to attach too many.

Does anyone have any suggestions? I know it's irrational but it really bugs me that it actually seemed to work briefly before developing this fault...



User avatar
Posts: 5874
Joined: Thu Oct 02, 2008 4:51 pm
Location: Manchester

Re: Faulty A3020

Postby danielj » Sun Sep 03, 2017 2:20 pm

First thing - I don't think your battery's going to be connected, just looking at corrosion there between the lower of the two -ve holes and the resistor. Check that for continuity. Then check continuity to the CMOS chip. Do you have the circuit diagrams? If not they're here:
http://chrisacorns.computinghistory.org ... awings.zip


User avatar
Posts: 7202
Joined: Mon Apr 18, 2011 4:46 pm
Location: Looking forward to summer in Somerset, UK...

Re: Faulty A3020

Postby 1024MAK » Sun Sep 03, 2017 3:24 pm

A PCB track is made of a copper conductor. On most boards, the bare copper is coated with a "tin" coating (which is a silver colour) so that it is easier to solder components to it. In areas where no component legs or pins will be connected, the copper tracks (and areas where there are no tracks) are protected with a solder resist layer. Often this solder resist layer is a bright colour, traditionally green was used, but many colours are now available. This solder resist layer is required for automated board assembly and automated machine soldering.

When a corrosive substance attacks a PCB, it finds small cracks and holes in the solder resist layer (which is not designed to protect against corrosive substances) or eats its way through the solder resist layer. It then attacks the metal copper track.

If left, eventually the full width of the copper track will be eaten away, resulting in the track no longer being an electrical conductor. Thin tracks die earlier than thicker tracks.

If a very thin sliver of copper track is left, say just enough for the machine to work, it's possible that for some tracks, the electrical current flowing through what is left of the track will cause localised heating (due to much of the copper having been eaten away) and then the thin sliver of copper will overheat and "blow" open circuit (a bit like a fuse wire melts).

To your eye, due to the colour difference between the part of the board that has the solder resist layer but did not have any copper track under it, and an area where there used to be a copper track (but which has been eaten away), you may think that there is still a track there. But if you look closely, what you can actually see, is the base PCB material, not metal.

All PCB tracks that have gone open circuit (broken) will have to be bypassed by routing a thin insulationed wire to bridge the break(s).

With boards where plated through hole vias are used (so a circuit can go from one side to another, or from one layer to another layer for boards that have copper tracks in the middle of the board), these are very common points to be damaged by corrosive liquids.

As modern boards can have very thin tracks, and these tracks can be hard to follow by eye, it's best to test using a multimeter on either the resistance range (200 ohm or equivalent range), or on the continuity range.

Test each track (in the area affected by the corrosive substance), at every component connection point and cross reference against the schematic diagram.

For a "Complete BBC Games Archive" visit www.bbcmicro.co.uk NOW!
BeebWiki‬ - for answers to many questions...

Posts: 503
Joined: Fri Aug 28, 2015 8:34 pm

Re: Faulty A3020

Postby SteveF » Sun Sep 03, 2017 4:03 pm

Thanks guys! Cheers for the background info Mark, that does make sense. I've had a look at the circuit diagrams Daniel mentioned and I may have found something, or I may be doing something stupid...

I'm using a multimeter on the 200 ohm range. If I connect it between the negative battery terminal on my holder and one side of R73, I get a reading of about 1.3 ohms; connecting to the other side of R73 gives a reading of about 183 ohms. Since R73 is a 180 ohm resistor, this seems good to me, and suggests that the corrosion damage visible in the photo between R73 and the lower -ve terminal from the CMOS battery isn't actually causing a problem.

However, if I try to do something similar between the positive battery terminal of my holder and R60, I always get infinite resistance. Indeed, if I touch the multimeter probes on both sides of R60 I still get infinite resistance. This makes me wonder if R60 itself has been damaged. However, is it possible that I'm simply touching the (tiny) plastic/ceramic package of R60 and not the actual metal terminals? I've experimented with a few other resistors on the board and generally I can get the expected resistance reading across them. Am I "supposed" to be able to touch the terminals of one of these surface mount resistors with a probe?

I've also tried measuring resistance between the positive battery terminal of my holder and R61 and I still get infinite resistance, even though I can measure the correct resistance across R61 itself (so my probes are probably making contact with its terminals.)

So I am tentatively inclined to deduce some sort of problem with R60 and/or the tracks on either side of it. I can't see those tracks, would I be right in assuming they are on the inner layers of the PCB? Assuming I'm right, does this mean the only way to fix this would be to solder a 180 ohm resistor along with a suitable length of insulated wire between the positive battery terminal and R61? Soldering the battery holder wires into the PCB holes for the CMOS battery was just about within my capabilities, but I fear this may be a bridge too far what with the surface mount components and all. Is there an easy option I'm missing?

(I can see there is a good connection between R61 and D15, although given that's in a very different area of the circuit board I guess that's not too surprising.)



ETA: Here's a crop of the relevant section of the circuit diagram for ease of reference:
circuit-diagram-crop.png (32.86 KiB) Viewed 103 times